[Ci-users] CentOS 8 and CentOS 8-Stream now available in CI

Tue Nov 5 22:28:57 UTC 2019
Fabian Arrotin <arrfab at centos.org>

On 05/11/2019 13:07, Vipul Siddharth wrote:
> On Tue, Nov 5, 2019 at 4:49 PM František Šumšal <frantisek at sumsal.cz> wrote:
>> Hello!
>> First of all - wonderful news! I went ahead and tried to switch our
>> RHEL8 systemd job to CentOS 8, but it looks like there an issue
>> with the internal repo mirrors:
> Thank a lot for reporting this,
> I will fix this as soon as possible.
>> ```
>> + dnf -v makecache
>> Loaded plugins: builddep, changelog, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repodiff, repograph, repomanage, reposync
>> DNF version: 4.0.9
>> cachedir: /var/cache/dnf
>> Making cache files for all metadata files.
>> AppStream: has expired and will be refreshed.
>> BaseOS: has expired and will be refreshed.
>> extras: has expired and will be refreshed.
>> repo: downloading from remote: AppStream
>> error: Status code: 404 for http://mirror.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
>> error: Status code: 404 for http://mirror2.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror2.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
>> error: Status code: 404 for http://mirror3.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror3.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
>> error: Status code: 404 for http://mirror4.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror4.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
>> error: Status code: 404 for http://mirror.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
>> CentOS-8 - AppStream                             17 kB/s | 244  B     00:00
>> Cannot download 'http://mirrorlist.centos.org/?release=8&arch=x86_64&repo=AppStream&infra=stock': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried.
>> Error: Failed to synchronize cache for repo 'AppStream'
>> ```
>> This happened on all CentOS 8 machines (haven't tried 8-stream) I got from
>> Duffy yesterday/today.
>> Thanks!

It's because the internal mirrorlist server in CI had not (yet) the
logic to parse repositories and so answer with correct URLs.
It's now done and working, but I'll sync with Vipul about this
 as deployed 8-stream nodes are actually deployed withut
centos-release-stream, so pointing by default to 8 and not 8-stream

Fabian Arrotin
The CentOS Project | https://www.centos.org
gpg key: 17F3B7A1 | twitter: @arrfab

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/ci-users/attachments/20191105/487b668c/attachment-0004.sig>