[CentOS-devel] Proper way to package Perl modules

Matt Martz centos at sivel.net
Fri Jun 15 10:17:30 UTC 2007


On 6/15/07, Kenneth Porter <shiva at sewingwitch.com> wrote:
>
> What's the expected way to package a Perl module? I want to build RPM's
> for
> several Perl modules and in the past on Fedora I'd use cpanflute2. What do
> I use on CentOS5? Is there a package to install to provide the necessary
> utility?
>
> I want to repackage the dependencies for MIMEDefang:
>
>         perl(MIME::Parser) is needed by mimedefang-2.62-1.i386
>         perl(MIME::Tools) >= 5.410 is needed by mimedefang-2.62-1.i386
>         perl(MIME::Words) is needed by mimedefang-2.62-1.i386
>         perl-IO-stringy is needed by mimedefang-2.62-1.i386
>         perl-MIME-tools is needed by mimedefang-2.62-1.i386
>         perl-MailTools is needed by mimedefang-2.62-1.i386


You would probably want to use cpan2rpm.

Looks like you can get it for CentOS5 at:

http://centos.karan.org/el5/extras/testing/i386/RPMS/


-- 
Matt Martz
mdmartz at sivel.net
CentOS Mirror Admin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos-devel/attachments/20070615/94c0915d/attachment.htm


More information about the CentOS-devel mailing list