[CentOS-devel] yum-3.2.8 for Centos 4 backport, part II.

William L. Maltby CentOS4Bill at triad.rr.com
Wed Jul 22 19:41:53 UTC 2009


On Wed, 2009-07-22 at 20:15 +0200, David Hrbáč wrote:
> William L. Maltby napsal(a):
> > 
> > David,
> > 
> > Thx for the work. I tried a test today and have a problem.
> > 
> > What I did was import your GPG.KEY file, manually added a .repo, and ran
> > yum with a --disablerepo=\* --enablerepo=hrb.
> > 
> > All seemed to go well.
> > 
> > I then did the same yum update command, but enabled the rpmforge repo to
> > try and pick up a new rtorrent moddule to test for Dag.
> > 
> > Results were a message saying "There was a problem importing one of the
> > Python modules required to run yum. The error leading to this problem
> > was: No module named op. Please install a package which provides this
> > module, or verify that the module is installed correctly".
> > 
> > Since I did my steps manually and am not real handy with this stuff, how
> > should I proceed to correct this?
> > 
> > Thanks,
> 
> William,
> repo has installer
> http://fs12.vsb.cz/hrb33/el4/hrb/stable/i386/repoview/hrb-release.html
> http://fs12.vsb.cz/hrb33/el4/hrb/stable/x86_64/repoview/hrb-release.html

Good. I'll run the i386 one now.

> 
> one installed disable stable repo.
> 1) what version of yum are you running?

Well, that machine is not used for much so I didn't worry about keeping
backup/previous version stuff. It was a full updated CentOS 4.7. So
whatever fully-updated yum is what I had.

> 2) what plugins?

All the plugins that come standard.

I know that may not be that helpful, but I didn't have a lot of time and
the machine wasn't critical, so I let things slide.

Now it has yum-utils-1.1.16-13.el4.hrb.1
           yum-plugin-fastestmirror-0.2.4-3.c4
           yum-metadata-parser-1.1.2-12.el4.hrb.1
           yum-plugin-priorities-0.0.7-2.c4 (enabled in all repos)
           yum-fastestmirror-1.1.16-13.el4.hrb.1
           yum-plugin-protectbase-1.1-1.c4 (disabled in all repos)

> 
> Please be aware that testing repo has a new version of yum 3.2.19, which
> is not production ready and the package is broken. I have been asking QA
> for yum-3.2.8-9.el4.hrb.2.1.5.noarch.rpm. Version 3.2.19 will follow
> soon, I"m running it now successfully with
> python-urlgrabber-3.1.0-5.el4.hrb.1.noarch.

Ok. That yum is the one I picked up: yum-3.2.19-18.el4.hrb.

Do I need to regress to stock from here or is there a quick and dirty
manual fix I can apply? I will run the relese file regardless.

> Regards,
> David
> <snip>

-- 
Bill



More information about the CentOS-devel mailing list