[CentOS] 2.6.9-34.EL kernel broken on i586?

Johnny Hughes mailing-lists at hughesjr.com
Sun Mar 12 10:58:37 UTC 2006


On Sat, 2006-03-11 at 23:10 -0600, Aleksandar Milivojevic wrote:
> My three basement machines got upgraded to 2.6.9-34.EL by nightly yum 
> cron job.  The two i686 seem to be fine.  However, on the old i586 
> machine I got hole bunch of warnings.  Haven't attempted rebooting it 
> with new kernel yet.  The warnings are:
> 
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/amd76x_edac.ko 
> needs unknown symbol edac_mc_del_mc
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/amd76x_edac.ko 
> needs unknown symbol edac_mc_find_mci_by_pdev
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/amd76x_edac.ko 
> needs unknown symbol edac_mc_add_mc
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/amd76x_edac.ko 
> needs unknown symbol edac_mc_alloc
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/amd76x_edac.ko 
> needs unknown symbol edac_mc_handle_ce
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/amd76x_edac.ko 
> needs unknown symbol edac_mc_handle_ue
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/e7xxx_edac.ko 
> needs unknown symbol edac_mc_del_mc
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/e7xxx_edac.ko 
> needs unknown symbol edac_mc_find_mci_by_pdev
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/e7xxx_edac.ko 
> needs unknown symbol edac_mc_add_mc
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/e7xxx_edac.ko 
> needs unknown symbol edac_mc_alloc
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/e7xxx_edac.ko 
> needs unknown symbol edac_mc_handle_ue_no_info
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/e7xxx_edac.ko 
> needs unknown symbol edac_mc_find_csrow_by_page
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/e7xxx_edac.ko 
> needs unknown symbol edac_mc_handle_ce
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/e7xxx_edac.ko 
> needs unknown symbol edac_mc_handle_ue
> WARNING: /lib/modules/2.6.9-34.EL/kernel/drivers/edac/e7xxx_edac.ko 
> needs unknown symbol edac_mc_handle_ce_no_info
> _______________________________________________

As everyone should know, CentOS is providing i586 support but i586
support is not provided upstream for EL4.  When issues like this come
up, CentOS has to find, fix and test the problems ourselves.

The 2 chipsets in question are not applicable to i586 machines, and the
chipsets that the are applicable for are i686 machines.  I am turning
off EDAC for these modules for the i586 arch.

I am rebuilding a new i586 kernel now, I'll send you an e-mail to test
it as soon as it is finished.

The i586 kernel you have should boot and work with those errors, as
those modules should not try to be loaded on a real i586 machine ... but
as soon as I have a replacement test kernel, I'll let you know.

Thanks,
Johnny Hughes
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.centos.org/pipermail/centos/attachments/20060312/9d896ec2/attachment.bin


More information about the CentOS mailing list