[CentOS] libgd question on CentOS (in order to get PerfParse working with Nagios)

Garrick Staples garrick at usc.edu
Wed Nov 28 22:02:50 UTC 2007


On Wed, Nov 28, 2007 at 01:05:58PM -0800, Rogelio alleged:
> Do I have the necessary gd packages installed on my CentOS 4 box?
> 
> rpm -qa | grep gd
> 
> gdk-pixbuf-0.22.0-17.el4.3
> gdk-pixbuf-devel-0.22.0-17.el4.3
> gdbm-1.8.0-24
> gdbm-devel-1.8.0-24
> gd-devel-2.0.28-5.4E
> gd-2.0.28-5.4E
> gdm-2.6.0.5-7.rhel4.15
> sysklogd-1.4.1-26_EL
> 
> I'm trying to install PerfParser (./compile->make && make install),
> but I'm getting a "gImageString error", which according to this FAQ
> (http://perfparse.de/tiki-view_faq.php?faqId=1) means:
> 
> "The gd library is probably not installed yet on your system. Or you
> are missing the development package such as libgd-devel or libgd-dev."

gd and gd-devel would appear to be the correct packages.  (gdi is something else)

Are you getting an error from configure or make?  Show us the exact command and
error message.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20071128/57f4a6ce/attachment.bin


More information about the CentOS mailing list