[CentOS] Re: USB printer goes into disconnected state when low-power mode enabled

MHR mhullrich at gmail.com
Sun Nov 23 23:42:01 UTC 2008


On Sun, Nov 23, 2008 at 3:05 PM, Mark Hull-Richter <mhullrich at gmail.com> wrote:
> I've mentioned this before, here, but with a laser printer connected via
> the lp0 port.
>
> I have a new laser printer, a Brother HL2140, that normally works just
> fine when installed using the CUPS interface per OpenPrinting's
> instructions (with one minor modification I had to add because the base
> driver without the CUPS installation did not work.
>
> Every so often, which actually appears to be every time the printer goes
> into power-saver mode, when I try to print something, I get this
> response in lpstat -t:
>
> [mhr at mhrichter ~]$ lpstat -t
> scheduler is running
> no system default destination
> device for HL2140: usb://Brother/HL-2140 series
> device for HPOJ4315: hp:/usb/Officejet_4300_series?serial=CN7AJH318W04GQ
> HL2140 accepting requests since Sun 23 Nov 2008 02:38:56 PM PST
> HPOJ4315 accepting requests since Sun 07 Sep 2008 12:52:14 AM PDT
> printer HL2140 now printing HL2140-2188.  enabled since Sun 23 Nov 2008
> 02:38:56 PM PST
>        Printer not connected; will retry in 30 seconds...
> printer HPOJ4315 is idle.  enabled since Sun 07 Sep 2008 12:52:14 AM PDT
> HL2140-2188             root             18432   Sun 23 Nov 2008
> 02:38:56 PM PST
>
> At one point, through some strange combination of:
>
> System->Administration->Printers
> Disable the printer
> cancel the print job (sometimes)
> disconnect the printer (USB cable out)
> power down the printer
> power the printer back on and wait for it to come ready
> reconnect the printer
> re-enable the printer
>
> liberally sprinkled with 30 second waits, I used to be able to get the
> printer to come back on line and print.
>
> Now I can't seem to get the <censored> thing to come back at all.
>
> Any suggestions on what to do to make this work?  I suppose I could
> reboot, but that _really_ defeats the purpose of using a USB printer in
> the first place.
>
> FTR, I also have an HP OfficeJet 4315 on a USB connection to the same
> system, and I _never_ have this problem with it.
>
> I'm running CentOS 5.2 x86_64 with all the latest updates, using the
> printer drivers from the OpenPrinting online database:
>
> brhl2140lpr-2.0.2-1.i386.rpm
> cupswrapperHL2140-2.0.2-1.i386.rpm
>
> Stumped.
>
> mhr
>

Mea culpa - I forgot:

I occasionally run Windows under VMWare, and whenever that is running,
I completely lose control of most USB devices, including the printer.

mhr


More information about the CentOS mailing list