[CentOS] octave

Tony Schreiner schreian at bc.edu
Mon Oct 20 13:48:15 UTC 2008


On Oct 18, 2008, at 3:58 AM, John R Pierce wrote:

> John wrote:
>> This one is for EPEL 5 on there site.
>> http://rpm.pbone.net/index.php3/stat/4/idpl/8177721/com/ 
>> hdf5-1.6.7-1.el5.i38
>> 6.rpm.html
>>
>
>
> I installed the hdf5 package off EPEL (via yum install hdf5) and my  
> yum install octave still fails with the same error.
>
> Error: Missing Dependency: libhdf5.so.0 is needed by package octave
>
> when I look at that hdf5 package, I see...
>
> # rpm -ql hdf5
> /usr/bin/gif2h5
> /usr/bin/h52gif
> ....

> /usr/share/doc/hdf5-1.8.0/README.txt
>
>
> libhdf5.so.5 and .5.0.0 and _hl.so.0  != what octave is looking  
> for.   I know EPEL isn't a CentOS project, IIRC, its a Fedora/RH  
> projecct but this isn't looking good.
>
>

Just to reassure you. I've had no problems with octave and hdf5  
( both from epel ).

 From what you've written, I don't think this it the problem, but  
just to be sure: are you running x86_64 and have installed i386 hdf5?

Tony Schreiner


More information about the CentOS mailing list