[CentOS] kickstart problems

Paolo Supino paolo.supino at gmail.com
Tue Sep 2 05:51:05 UTC 2008


Hi Nate

  Autoconfiguration failure makes sense, but it's not a drivers issue:
1: It's a broadcom tg3 driver that is well supported in the kernel.
2: the kernel fetches successfully the kickstart configuration file I supply
it in the command line and
3: After the error comes up I get the HTTP setup configuration screen with
the source website (in IP) and CentOS directory as I entered them in the
pxeconfiguration file and as it appears in the kickstart configuration file
and all I have to do is press the 'OK' button to continue the installation
to a successful completion.
4. Sniffing the network showed the following: the kernel fetches the
kickstart file, fails to fetch 'product.img' file prints out the error
message of being unable to fetch 'stage2.img' file and only when I press the
'OK'  button in the HTTP setup window actually contacts the HTTP server and
successfully fetches 'stage2.img' file.

  My guess is that my configuration isn't handled properlly by anaconda, I
just need to find out where (or change my configuration so that anaconda
will handle it properly).

  I (out of haste of getting this email out) omitted the configuration files
I use in the kickstart configuration. So here they are ...
pxelinux.cfg/C0A80B02:
default ks
prompt 0
label ks
        kernel vmlinuz
        append initrd=initrd.img ramdisk_size=9216 ksdevice=bootif noapic
acpi=off ks=http://192.168.11.1/kickstart/n002.ks
        ipappend 2

kickstart configuration file:
# Kickstart file automatically generated by anaconda.

install
lang en_US.UTF-8
keyboard us
network --device eth0 --bootproto static --ip 192.168.11.2 --netmask
255.255.255.0 --gateway 192.168.11.1 --nameserver=192.168.11.1 --hostname
n002.example.com
network --device eth1 --onboot no --bootproto dhcp --hostname
n002.example.com
network --device eth2 --onboot no --bootproto dhcp --hostname
n002.example.com
network --device eth3 --onboot no --bootproto dhcp --hostname
n002.example.com

url --url http://192.168.11.1/source
rootpw --iscrypted ?????????????????????????????????
firewall --disabled
authconfig --enableshadow --enablemd5
selinux --disabled
timezone --utc Asia/Jerusalem
bootloader --location=mbr --driveorder=sda --append="noapic acpi=off"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
zerombr
clearpart --all --drives=sda
part /boot --fstype ext3 --size=100 --ondisk=sda
.
.
.



On Mon, Sep 1, 2008 at 5:03 PM, nate <centos at linuxpowered.net> wrote:

> Paolo Supino wrote:
>
> >   Has anyone encounter this problem and has a solution for it?
>
> Network autoconfiguration failed, most likely there is not
> a compatible driver for the network card in your system.
>
> If there is a driver disk for that NIC you can use that, what
> I typically have done in the past is build an updated driver from
> source and insert it into the installation program which is a
> fairly complicated process involving extracting the initrd, the
> modules.cgz inside of it, putting the compatible driver built
> against the same kernel into the modules config and recompressing
> the modules file, updating the pci device table for the new device,
> and rebuilding the initrd. Also adding a step in the %post section
> to install a compatible driver with whatever kernel the installer
> ends up installing so when the system reboots it has network
> connectivity.
>
> I also repeat the first part of the process where I insert the
> kernel, again in the stage 2 netinst.img? file(forgot off hand
> exactly what the file is called), it may not be required for
> network drivers, but I think it is for storage drivers, I forget,
> been a while since I had to do it.
>
> nate
>
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20080902/23206b5d/attachment.htm


More information about the CentOS mailing list