[CentOS] Upgrade

Thomas Dukes tdukes at sc.rr.com
Wed Apr 1 12:58:13 UTC 2009


 

> -----Original Message-----
> From: centos-bounces at centos.org 
> [mailto:centos-bounces at centos.org] On Behalf Of Michael A. Peters
> Sent: Wednesday, April 01, 2009 7:31 AM
> To: CentOS mailing list
> Subject: Re: [CentOS] Upgrade
> 
> Thomas Dukes wrote:
> >  
> > 
> >> -----Original Message-----
> >> From: centos-bounces at centos.org
> >> [mailto:centos-bounces at centos.org] On Behalf Of Ned Slider
> >> Sent: Tuesday, March 31, 2009 10:34 PM
> >> To: CentOS mailing list
> >> Subject: Re: [CentOS] Upgrade
> >>
> >> Thomas Dukes wrote:
> >>> Hello,
> >>>
> >>> Just did yum update.  There were numerous packages to be
> >> updated.  I
> >>> get this is the newest release of Centos.
> >>>
> >>> The update bombed stating I need nss-3.12.2.0-2.el5.  I did
> >> a rpm -q
> >>> nss and
> >>> nss-3.12.2.0-4.el5 is install in Cento 5.2.
> >>>
> >>> What's up with that?
> >>>
> >>> TIA
> >>>
> >> You didn't wait for the official release announcement ;)
> > 
> > Good one!!  :-)
> > 
> > Wasn't trying to upgrade to the newest release.  I run a 
> 'yum update' daily.
> > I only have Centos repos installed so I don't know how I have a 
> > version of nss newer in 5.2 than 5.3.
> 
> Try the following:
> 
> rpm -q --queryformat \
> '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH} Vendor: %{vendor}\n' nss
> 
> I get the following:
> 
> nss-3.12.2.0-4.el5.centos.x86_64 Vendor: CentOS
> nss-3.12.2.0-4.el5.centos.i386 Vendor: CentOS
> 
I have the same:  nss-3.12.2.0-4.el5.centos.i386 Vendor: CentOS

> That looks like what you have. So the question then is what 
> requires the
> 2.el5 release?
> 
> That's strange because the version is the same, it is 
> nitpicking over the release. Unless there is an epoch 
> involved, it seems some package somewhere might have a 
> release specific requirement, which is suppose to be a nono.
> 
> Try yum --exclude=nss update
> 
> and see if it tells you what package is bombing out on the upgrade.

The error I got when I ran 'yum update' was:

Error:  Missing Dependency: nss = 3.12.2.0-2-el5.centos is needed by package
nss-devel

Maybe all the packages (nss) weren't available on the mirror at the time I
ran the update.  I see where nss-devel is 'set to be updated' but I don't
see nss in the list.

Thanks



More information about the CentOS mailing list