[CentOS] xCache install error ($PHP_AUTOCONF?)

James Bensley jwbensley at gmail.com
Wed Jan 7 07:30:30 UTC 2009


Hey Kai, thanks for the response, I think I have found the problem;

For some reason if I download the source for xCache or eAccelerator
and unpack the tar ball then change to that directory and run phpize I
still get the error:
Cannot find autoconf. Please check your autoconf installation and the
$PHP_AUTOCONF
environment variable is set correctly and then rerun this script.

But someone has posted a source rpm online for download to compile
into a binary rpm but when I do I get the error:
[root at server1882 /]# rpmbuild -bb /usr/src/redhat/SPECS/php-xcache.spec
error: Failed build dependencies:
        php is needed by php-xcache-5.2.5_1.2.1-jason.1.x86_64
        php-devel is needed by php-xcache-5.2.5_1.2.1-jason.1.x86_64

It can't see that php and php-devel are installed but they are, and
running beautifully? So I'm guessing that phpize is having the same
problems in that it can't seem to understand that fact the autoconf,
autoheader, libtool, m4, make etc they are all installed and working?

Does anyone have any idea why this might be?

-----BEGIN GEEK CODE BLOCK-----
  Version: 3.1
GIT/MU/U dpu s: a--> C++>$ U+> L++> B-> P+> E?> W+++>$ N K W++ O M++>$ V-
PS+++ PE++ Y+ PGP t 5 X+ R- tv+ b+> DI D+++ G+ e(+++++) h--(++) r++ z++
------END GEEK CODE BLOCK------


More information about the CentOS mailing list