[CentOS] xCache install error ($PHP_AUTOCONF?)

David Hrbác( hrbac.conf at seznam.cz
Wed Jan 7 08:51:55 UTC 2009


James Bensley napsal(a):
> Hey Kai, thanks for the response, I think I have found the problem;
> 
> For some reason if I download the source for xCache or eAccelerator
> and unpack the tar ball then change to that directory and run phpize I
> still get the error:
> Cannot find autoconf. Please check your autoconf installation and the
> $PHP_AUTOCONF
> environment variable is set correctly and then rerun this script.
> 
> But someone has posted a source rpm online for download to compile
> into a binary rpm but when I do I get the error:
> [root at server1882 /]# rpmbuild -bb /usr/src/redhat/SPECS/php-xcache.spec
> error: Failed build dependencies:
>         php is needed by php-xcache-5.2.5_1.2.1-jason.1.x86_64
>         php-devel is needed by php-xcache-5.2.5_1.2.1-jason.1.x86_64
> 
> It can't see that php and php-devel are installed but they are, and
> running beautifully? So I'm guessing that phpize is having the same
> problems in that it can't seem to understand that fact the autoconf,
> autoheader, libtool, m4, make etc they are all installed and working?
> 
> Does anyone have any idea why this might be?


Hi,
Do you have autoconf intalled?

rpm -qp --requires php-xcache-1.2.1-jason.1.src.rpm
yum install php-devel autoconf automake libtool
rpmbuild --rebuild php-xcache-1.2.1-jason.1.src.rpm
rpm -ivh /usr/src/redhat/RPMS/i386/php-xcache-5.1.6_1.2.1-jason.1.i386.rpm

BTW: Centos 4/5 binaries are also here:
http://fs12.vsb.cz/hrb33/el4/hrb/stable/x86_64/repodata/repoview/php-xcache-0-1.2.2-1.el4.hrb.html
http://fs12.vsb.cz/hrb33/el4/hrb/stable/i386/repodata/repoview/php-xcache-0-1.2.2-1.el4.hrb.html
http://fs12.vsb.cz/hrb33/el5/hrb/stable/x86_64/repodata/repoview/php-xcache-0-1.2.2-1.el5.hrb.html
http://fs12.vsb.cz/hrb33/el5/hrb/stable/i386/repodata/repoview/php-xcache-0-1.2.2-1.el5.hrb.html

Regards,
David Hrbác(



More information about the CentOS mailing list