[CentOS] xCache install error ($PHP_AUTOCONF?)

James Bensley jwbensley at gmail.com
Wed Jan 7 10:53:29 UTC 2009


Hi David,

> Well,
> you should mention it first you are running RHEL 3.x.

Yes, my bad, sorry about that!

>So you are running
> php 4.3.2. Package you are trying to install is built agains Centos 4
> Plus php.

I have php 4.4.9. Yeah I was hoping the CentOS 4 build might work on
RHEL 3.4.5-2?

> James, do rpm -qa | grep php | sort.

This brings back nothing indicating that php isn't installed but it
DEFFINATLY is, however we/I/the web dev team compiled it from the
source not through rpms (as I didn't actually think it was available
this way?) so might it not show up for that reason?

> Btw, php-xcache SRPM buils fine on centos 3.x, I have just tried.

I did try to build the source RPM but get:

php is needed by php-xcache-4.4.9_1.2.1-jason.1.x86_64
php-devel is needed by php-xcache-4.4.9_1.2.1-jason.1.x86_64

So I'm lost, both of these are installed but the rpm manager can't
detect them? What am I going to do? I am at a bit of a loss here!

Regards,
James

-----BEGIN GEEK CODE BLOCK-----
  Version: 3.1
GIT/MU/U dpu s: a--> C++>$ U+> L++> B-> P+> E?> W+++>$ N K W++ O M++>$ V-
PS+++ PE++ Y+ PGP t 5 X+ R- tv+ b+> DI D+++ G+ e(+++++) h--(++) r++ z++
------END GEEK CODE BLOCK------


More information about the CentOS mailing list