[CentOS] Ldap login

Didi ribalba at gmail.com
Mon Jan 26 16:12:15 UTC 2009


On Mon, Jan 26, 2009 at 3:58 PM, Per Qvindesland <per at norhex.com> wrote:
> Hi Didi
>
> Thanks again for your help.
>
> When I type ldapsearch -x it comes up with the complete list of users and
> groups, but if i do the ldapsearch -v it gives me the same error:
> SASL/EXTERNAL authentication started
> ldap_sasl_interactive_bind_s:unknown authentication method (-6) additional
> info:sasl(-4): no mechanism available:

Does your server/cleint have ssl? How secure does this have to be.
Normally you have to set up the certificates to do it over SASL. If it
is at home and you don't need to be bullet proof you can just use
simple auth. I know people are going to hate me because of this, but
if you just want it to work this might be an option.


> Any idea of what authentication method ldap uses?
http://en.wikipedia.org/wiki/Simple_Authentication_and_Security_Layer

might explain a few things.

Cheers Didi

>
> Regards
> Per
>
> On 1/26/09 4:34 PM, "Didi" <ribalba at gmail.com> wrote:
>
>>> I tried that and I am getting this error:
>>> ldap_sasl_interactive_bind_s:unknown authentication method (-6) additional
>>> info:sasl(-4): no mechanism available:
>>>
>>> Any idea?
>>
>> It looks like your server does not know the authentication method.
>> Does it work with 'ldapsearch -x' ?
>> And ldapsearch -v should tell you more
>>
>> Cheers Didi
>> ----
>> www.ribalba.de
>> Email / Jabber: ribalba at gmail.com
>> Skype : ribalba
>>
>>
>>
>> On Mon, Jan 26, 2009 at 2:48 PM, Per Qvindesland <per at norhex.com> wrote:
>>> Hi
>>>
>>> Thanks for replying.
>>>
>>> Regards
>>> Per Qvindesland
>>>
>>>
>>> On 1/26/09 2:43 PM, "Didi Hoffmann" <ribalba at gmail.com> wrote:
>>>
>>>>>
>>>>> Hello List,
>>>>>
>>>>> I have installed Centos Directory Server to be able to authenticate
>>>>> with ldap on the other servers in the system, the directory server
>>>>> seems to be working fine, but when I configure a test server to
>>>>> authenticate up against this server then it says that there is no
>>>>> such user, I have made sure that the config is correct on the
>>>>> client /etc/ldap.conf is there also the /etc/openldap/ldap.conf is
>>>>> there and both is configured correctly, i have tried to telnet from
>>>>> the client to the server on port 389 and that also works.
>>>>>
>>>>> Does anyone have any idea of what I am missing here?
>>>>>
>>>>>
>>>>> Thanks in advance
>>>>>
>>>>> Regards
>>>>> Per Qvindesland
>>>>> _______________________________________________
>>>>> CentOS mailing list
>>>>> CentOS at centos.org
>>>>> http://lists.centos.org/mailman/listinfo/centos
>>>>
>>>> Maybe ldapsearch will help. Try connecting with ldapsearch to the
>>>> server and see if that works.
>>>>
>>>> _______________________________________________
>>>> CentOS mailing list
>>>> CentOS at centos.org
>>>> http://lists.centos.org/mailman/listinfo/centos
>>>
>>>
>>> _______________________________________________
>>> CentOS mailing list
>>> CentOS at centos.org
>>> http://lists.centos.org/mailman/listinfo/centos
>>>
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> http://lists.centos.org/mailman/listinfo/centos
>
>
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>


More information about the CentOS mailing list