[CentOS] screwed up dependencies

Nicolas Thierry-Mieg Nicolas.Thierry-Mieg at imag.fr
Fri Nov 6 12:58:16 UTC 2009


ken wrote:
> Subsequent to trying to "yum update"-- it failed--, I tried to resolve
> the dependencies piecemeal:
> 
> # yum update faad2
> ....
> --> Processing Dependency: libfaad.so.0 for package: ffmpeg
> ---> Package faad2.i386 0:2.7-1.el5.rf set to be updated
> --> Finished Dependency Resolution
> ffmpeg-0.5-2.el5.rf.i386 from installed has depsolving problems
>   --> Missing Dependency: libfaad.so.0 is needed by package
> ffmpeg-0.5-2.el5.rf.i386 (installed)
> Error: Missing Dependency: libfaad.so.0 is needed by package
> ffmpeg-0.5-2.el5.rf.i386 (installed)
> ....
> 
> # rpm -q ffmpeg
> ffmpeg-0.5-2.el5.rf
> 
> Could it be that there's a packaging error in faad2 ?
> 

looks like it, but this is an rpmforge package so it should be discussed 
on the rpmforge list (Cc'd here).
Maybe give it a day and try again.
Meanwhile yum --skip-broken could be your friend.



More information about the CentOS mailing list