[CentOS] Upgrading CentOS 5.3 to 5.4 errors

Robert kerplop at sbcglobal.net
Sun Oct 25 00:46:01 UTC 2009



Rohan Gilchrist wrote:
> Hello,
>
> I thought I'd wait a little while before upgrading to 5.4, but am 
> running into the following errors:
>
> -> Finished Dependency Resolution
> lvm2-2.02.46-8.el5.i386 from base has depsolving problems
>   --> Missing Dependency: device-mapper >= 1.02.32-1 is needed by 
> package lvm2-2.02.46-8.el5.i386 (base)
> mkinitrd-5.1.19.6-54.i386 from base has depsolving problems
>   --> Missing Dependency: device-mapper-multipath >= 0.4.7-9 is needed 
> by package mkinitrd-5.1.19.6-54.i386 (base)
> lvm2-2.02.46-8.el5.i386 from base has depsolving problems
>   --> Missing Dependency: device-mapper-event is needed by package 
> lvm2-2.02.46-8.el5.i386 (base)
> Error: Missing Dependency: device-mapper-multipath >= 0.4.7-9 is needed 
> by package mkinitrd-5.1.19.6-54.i386 (base)
> Error: Missing Dependency: device-mapper-event is needed by package 
> lvm2-2.02.46-8.el5.i386 (base)
> Error: Missing Dependency: device-mapper >= 1.02.32-1 is needed by 
> package lvm2-2.02.46-8.el5.i386 (base)
>
> It would appear that these packages do exist, although earlier versions:
>
> # rpm -q device-mapper
> device-mapper-1.02.13-1.el5
>
> Any thoughts would be appreaicated.
>
> Regards,
>
> Rohan.
>   
1. Did you follow the procedure in the 5.4 Release Notes (repeated in 
the release announcement)?

2. Perhaps the repo(s) you're using is/are broken. My DVD contains 
(among otherstuf) lvm2-2.02.46-8.el5.i386.rpm and  
device-mapper-1.02.13.1.el5.i386.rpm so that that particular dependency 
would be resolved easily enough.




More information about the CentOS mailing list