[CentOS] totem: something wrong with gstreamer-plugins-ugly

ken gebser at mousecar.com
Sun Jan 24 18:36:15 UTC 2010


On 01/24/2010 12:47 PM ken wrote:
> When running totem to play a move (e.g. mpeg-1 file), it fails with the
> message: "A MPEG-1 System Stream demuxer plugin is required to play this
> stream, but not installed."
> 
> After reading docs and trying various things I've reduced the source of
> the problem to the package gstreamer-plugins-ugly-0.10.11-1.el5.rf.i386.rpm
> 
> # rpm --rebuilddb
> # rpm -q libdvdread
> libdvdread-4.1.3-1.el5
> # rpm -i gstreamer-plugins-ugly-0.10.11-1.el5.rf.i386.rpm
> error: Failed dependencies:
>         libdvdread.so.3 is needed by
> gstreamer-plugins-ugly-0.10.11-1.el5.rf.i386
> 
> And, after erasing libdvdread and trying to install both packages in one
> command, I get pretty much the same contradictory error message:
> 
> # rpm -iv libdvdread-4.1.3-1.el5.i386.rpm
> gstreamer-plugins-ugly-0.10.11-1.el5.rf.i386.rpm
> error: Failed dependencies:
>         libdvdread.so.3 is needed by
> gstreamer-plugins-ugly-0.10.11-1.el5.rf.i386
> 
> There's no problem installing libdvdread by itself:
> # rpm -iv libdvdread-4.1.3-1.el5.i386.rpm
> Preparing packages for installation...
> libdvdread-4.1.3-1.el5
> # rpm -q libdvdread
> libdvdread-4.1.3-1.el5
> 
> 
> So how are people getting totem to play movies?
> 
> tia.

Also:

# rpm -q gstreamer-plugins-ugly
package gstreamer-plugins-ugly is not installed
# yum install gstreamer-plugins-ugly
...
gstreamer-plugins-ugly-0.10.11-1.el5.rf.i386 from rpmforge has
depsolving problems
  --> Missing Dependency: libdvdread.so.3 is needed by package
gstreamer-plugins-ugly-0.10.11-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libdvdread.so.3 is needed by package
gstreamer-plugins-ugly-0.10.11-1.el5.rf.i386 (rpmforge)
....

So is there an upgrade to gstreamer-plugins-ugly which looks for the
upgraded libdvdread?




More information about the CentOS mailing list