[CentOS] Dependency problems with Yum update

Todd Cary todd at aristesoftware.com
Wed Mar 10 22:53:15 UTC 2010


Using the -d8 here is what I get...a lot of info!!

Resolving for requirement: liblber-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of liblber-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing liblber-2.2.so.7: u
Cannot find an update path for dep for: liblber-2.2.so.7
Searching pkgSack for dep: liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for liblber-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 43/54
evolution requires: libldap-2.2.so.7
--> Processing Dependency: libldap-2.2.so.7 for package: evolution
Calling rpmdb.returnHeaderByTuple on evolution.i386 0:2.0.2-41.el4_7.2
Requiring package is installed: evolution - 2.0.2-41.el4_7.2.i386
Resolving for installed requiring package: evolution - 2.0.2-41.el4_7.2.i386
Resolving for requirement: libldap-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of libldap-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing libldap-2.2.so.7: u
Cannot find an update path for dep for: libldap-2.2.so.7
Searching pkgSack for dep: libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for libldap-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 44/54
squid requires: liblber-2.2.so.7
--> Processing Dependency: liblber-2.2.so.7 for package: squid
Calling rpmdb.returnHeaderByTuple on squid.i386 7:2.5.STABLE14-4.el4
Requiring package is installed: squid - 7:2.5.STABLE14-4.el4.i386
Resolving for installed requiring package: squid - 7:2.5.STABLE14-4.el4.i386
Resolving for requirement: liblber-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of liblber-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing liblber-2.2.so.7: u
Cannot find an update path for dep for: liblber-2.2.so.7
Searching pkgSack for dep: liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for liblber-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 45/54
python-ldap requires: libldap_r-2.2.so.7
--> Processing Dependency: libldap_r-2.2.so.7 for package: python-ldap
Calling rpmdb.returnHeaderByTuple on python-ldap.i386 0:2.0.1-2
Requiring package is installed: python-ldap - 2.0.1-2.i386
Resolving for installed requiring package: python-ldap - 2.0.1-2.i386
Resolving for requirement: libldap_r-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of libldap_r-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing libldap_r-2.2.so.7: u
Cannot find an update path for dep for: libldap_r-2.2.so.7
Searching pkgSack for dep: libldap_r-2.2.so.7
Potential match for libldap_r-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
libldap_r-2.2.so.7
Potential match for libldap_r-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
libldap_r-2.2.so.7
Potential match for libldap_r-2.2.so.7 from openldap - 
2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for libldap_r-2.2.so.7
Potential match for libldap_r-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for libldap_r-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 46/54
samba requires: libldap-2.2.so.7
--> Processing Dependency: libldap-2.2.so.7 for package: samba
Calling rpmdb.returnHeaderByTuple on samba.i386 0:3.0.33-0.18.el4_8.1
Requiring package is installed: samba - 3.0.33-0.18.el4_8.1.i386
Resolving for installed requiring package: samba - 3.0.33-0.18.el4_8.1.i386
Resolving for requirement: libldap-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of libldap-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing libldap-2.2.so.7: u
Cannot find an update path for dep for: libldap-2.2.so.7
Searching pkgSack for dep: libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for libldap-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 47/54
samba-client requires: libldap-2.2.so.7
--> Processing Dependency: libldap-2.2.so.7 for package: samba-client
Calling rpmdb.returnHeaderByTuple on samba-client.i386 0:3.0.33-0.18.el4_8.1
Requiring package is installed: samba-client - 3.0.33-0.18.el4_8.1.i386
Resolving for installed requiring package: samba-client - 
3.0.33-0.18.el4_8.1.i386
Resolving for requirement: libldap-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of libldap-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing libldap-2.2.so.7: u
Cannot find an update path for dep for: libldap-2.2.so.7
Searching pkgSack for dep: libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for libldap-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 48/54
MySQL-python requires: libmysqlclient_r.so.14(libmysqlclient_14)
--> Processing Dependency: libmysqlclient_r.so.14(libmysqlclient_14) for 
package: MySQL-python
Calling rpmdb.returnHeaderByTuple on MySQL-python.i386 0:1.2.1_p2-1.el4.1
Requiring package is installed: MySQL-python - 1.2.1_p2-1.el4.1.i386
Resolving for installed requiring package: MySQL-python - 
1.2.1_p2-1.el4.1.i386
Resolving for requirement: libmysqlclient_r.so.14(libmysqlclient_14)
Needed Require is not a package name. Looking up: 
libmysqlclient_r.so.14(libmysqlclient_14)
Potential Provider: mysql.i386 0:4.1.22-2.el4
Mode is u for provider of libmysqlclient_r.so.14(libmysqlclient_14): 
mysql.i386 0:4.1.22-2.el4
Mode for pkg providing libmysqlclient_r.so.14(libmysqlclient_14): u
Cannot find an update path for dep for: 
libmysqlclient_r.so.14(libmysqlclient_14)
Searching pkgSack for dep: libmysqlclient_r.so.14(libmysqlclient_14)
Potential match for libmysqlclient_r.so.14(libmysqlclient_14) from mysql 
- 4.1.22-2.el4_8.3.i386
Matched mysql - 4.1.22-2.el4_8.3.i386 to require for 
libmysqlclient_r.so.14(libmysqlclient_14)
Potential match for libmysqlclient_r.so.14(libmysqlclient_14) from mysql 
- 4.1.22-2.el4.i386
Matched mysql - 4.1.22-2.el4.i386 to require for 
libmysqlclient_r.so.14(libmysqlclient_14)
mysql - 4.1.22-2.el4.i386 is in providing packages but it is already 
installed, removing.
Potential resolving package mysql - 4.1.22-2.el4_8.3.i386 has newer 
instance in ts.

Dep Number: 49/54
cyrus-sasl requires: liblber-2.2.so.7
--> Processing Dependency: liblber-2.2.so.7 for package: cyrus-sasl
Calling rpmdb.returnHeaderByTuple on cyrus-sasl.i386 0:2.1.19-14
Requiring package is installed: cyrus-sasl - 2.1.19-14.i386
Resolving for installed requiring package: cyrus-sasl - 2.1.19-14.i386
Resolving for requirement: liblber-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of liblber-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing liblber-2.2.so.7: u
Cannot find an update path for dep for: liblber-2.2.so.7
Searching pkgSack for dep: liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for liblber-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 50/54
dovecot requires: libldap-2.2.so.7
--> Processing Dependency: libldap-2.2.so.7 for package: dovecot
Calling rpmdb.returnHeaderByTuple on dovecot.i386 0:0.99.11-9.EL4
Requiring package is installed: dovecot - 0.99.11-9.EL4.i386
Resolving for installed requiring package: dovecot - 0.99.11-9.EL4.i386
Resolving for requirement: libldap-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of libldap-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing libldap-2.2.so.7: u
Cannot find an update path for dep for: libldap-2.2.so.7
Searching pkgSack for dep: libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for libldap-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 51/54
samba requires: liblber-2.2.so.7
--> Processing Dependency: liblber-2.2.so.7 for package: samba
Calling rpmdb.returnHeaderByTuple on samba.i386 0:3.0.33-0.18.el4_8.1
Requiring package is installed: samba - 3.0.33-0.18.el4_8.1.i386
Resolving for installed requiring package: samba - 3.0.33-0.18.el4_8.1.i386
Resolving for requirement: liblber-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of liblber-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing liblber-2.2.so.7: u
Cannot find an update path for dep for: liblber-2.2.so.7
Searching pkgSack for dep: liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for liblber-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 52/54
cyrus-sasl requires: libldap-2.2.so.7
--> Processing Dependency: libldap-2.2.so.7 for package: cyrus-sasl
Calling rpmdb.returnHeaderByTuple on cyrus-sasl.i386 0:2.1.19-14
Requiring package is installed: cyrus-sasl - 2.1.19-14.i386
Resolving for installed requiring package: cyrus-sasl - 2.1.19-14.i386
Resolving for requirement: libldap-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of libldap-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing libldap-2.2.so.7: u
Cannot find an update path for dep for: libldap-2.2.so.7
Searching pkgSack for dep: libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for libldap-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 53/54
autofs requires: libldap-2.2.so.7
--> Processing Dependency: libldap-2.2.so.7 for package: autofs
Calling rpmdb.returnHeaderByTuple on autofs.i386 1:4.1.3-238
Requiring package is installed: autofs - 1:4.1.3-238.i386
Resolving for installed requiring package: autofs - 1:4.1.3-238.i386
Resolving for requirement: libldap-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of libldap-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing libldap-2.2.so.7: u
Cannot find an update path for dep for: libldap-2.2.so.7
Searching pkgSack for dep: libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for libldap-2.2.so.7
Potential match for libldap-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for libldap-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one

Dep Number: 54/54
mod_authz_ldap requires: liblber-2.2.so.7
--> Processing Dependency: liblber-2.2.so.7 for package: mod_authz_ldap
Calling rpmdb.returnHeaderByTuple on mod_authz_ldap.i386 0:0.26-2.1
Requiring package is installed: mod_authz_ldap - 0.26-2.1.i386
Resolving for installed requiring package: mod_authz_ldap - 0.26-2.1.i386
Resolving for requirement: liblber-2.2.so.7
Needed Require has already been looked up, cheating
Potential Provider: openldap.i386 0:2.2.13-12.el4_8.2
Mode is u for provider of liblber-2.2.so.7: openldap.i386 
0:2.2.13-12.el4_8.2
Mode for pkg providing liblber-2.2.so.7: u
Cannot find an update path for dep for: liblber-2.2.so.7
Searching pkgSack for dep: liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.27_2.2.29-4.el4.centos.i386
Matched compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from compat-openldap - 
2.3.19_2.2.29-4.centos.i386
Matched compat-openldap - 2.3.19_2.2.29-4.centos.i386 to require for 
liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4_8.2.i386
Matched openldap - 2.2.13-12.el4_8.2.i386 to require for liblber-2.2.so.7
Potential match for liblber-2.2.so.7 from openldap - 2.2.13-12.el4.i386
Matched openldap - 2.2.13-12.el4.i386 to require for liblber-2.2.so.7
Potential resolving package compat-openldap - 
2.3.19_2.2.29-4.centos.i386 has newer instance in ts.
openldap - 2.2.13-12.el4_8.2.i386 is in providing packages but it is 
already installed, removing.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance in ts.
Potential resolving package openldap - 2.2.13-12.el4.i386 has newer 
instance installed.
compat-openldap already in ts, skipping this one
miss = 6
conf = 0
CheckDeps = 48
--> Restarting Dependency Resolution with new changes.
---> Loop Number: 2
Restarting Loop
--> Populating transaction set with selected packages. Please wait.
Member: openoffice.org-i18n.i386 0-1.1.5-10.6.0.7.EL4.3 - u
Member: openldap-devel.i386 0-2.3.27-4.el4.centos - u
Member: yum-metadata-parser.i386 0-1.1.0-2.el4.centos - u
Member: openoffice.org-libs.i386 0-1.1.5-10.6.0.7.EL4.3 - u
Member: xchat.i386 1-2.4.5-1.el4.centos - u
Member: compat-openldap.i386 0-2.3.27_2.2.29-4.el4.centos - u
Adding Package compat-openldap - 2.3.27_2.2.29-4.el4.centos.i386 in mode u
---> Package compat-openldap.i386 0:2.3.27_2.2.29-4.el4.centos set to be 
updated
Member: mysql-server.i386 0-5.0.82sp1-1.el4_8 - u
Member: pidgin.i386 0-2.6.6-1.el4 - u
Member: openldap.i386 0-2.3.27-4.el4.centos - u
Member: systemtap-runtime.i386 0-0.6.2-2.el4_8.1 - u
Member: openldap-clients.i386 0-2.3.27-4.el4.centos - u
Member: mysql-devel.i386 0-5.0.82sp1-1.el4_8 - u
Member: mysql-libs.i386 0-5.0.82sp1-1.el4_8 - u
Member: openoffice.org.i386 0-1.1.5-10.6.0.7.EL4.3 - u
Member: mysql.i386 0-5.0.82sp1-1.el4_8 - u
Member: firefox.i386 0-3.0.18-1.el4.centos - u
Member: systemtap.i386 0-0.6.2-2.el4_8.1 - u
Member: ruby-mode.i386 0-1.8.5-5.el4.centos.1 - u
Member: libpurple.i386 0-2.6.6-1.el4 - u
Member: perl-Compress-Zlib.i386 0-1.42-1.el4.centos - u
--> Running transaction check
# of Deps = 6

Dep Number: 1/6
dovecot requires: libmysqlclient.so.14(libmysqlclient_14)
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for 
package: dovecot
Calling rpmdb.returnHeaderByTuple on dovecot.i386 0:0.99.11-9.EL4
Requiring package is installed: dovecot - 0.99.11-9.EL4.i386
Resolving for installed requiring package: dovecot - 0.99.11-9.EL4.i386
Resolving for requirement: libmysqlclient.so.14(libmysqlclient_14)
Needed Require is not a package name. Looking up: 
libmysqlclient.so.14(libmysqlclient_14)
Potential Provider: mysql.i386 0:4.1.22-2.el4
Mode is u for provider of libmysqlclient.so.14(libmysqlclient_14): 
mysql.i386 0:4.1.22-2.el4
Mode for pkg providing libmysqlclient.so.14(libmysqlclient_14): u
Cannot find an update path for dep for: 
libmysqlclient.so.14(libmysqlclient_14)
Searching pkgSack for dep: libmysqlclient.so.14(libmysqlclient_14)
Potential match for libmysqlclient.so.14(libmysqlclient_14) from mysql - 
4.1.22-2.el4_8.3.i386
Matched mysql - 4.1.22-2.el4_8.3.i386 to require for 
libmysqlclient.so.14(libmysqlclient_14)
Potential match for libmysqlclient.so.14(libmysqlclient_14) from mysql - 
4.1.22-2.el4.i386
Matched mysql - 4.1.22-2.el4.i386 to require for 
libmysqlclient.so.14(libmysqlclient_14)
mysql - 4.1.22-2.el4.i386 is in providing packages but it is already 
installed, removing.
Potential resolving package mysql - 4.1.22-2.el4_8.3.i386 has newer 
instance in ts.

Dep Number: 2/6
perl-DBD-MySQL requires: libmysqlclient.so.14
--> Processing Dependency: libmysqlclient.so.14 for package: perl-DBD-MySQL
Calling rpmdb.returnHeaderByTuple on perl-DBD-MySQL.i386 
0:2.9004-3.1.centos4
Requiring package is installed: perl-DBD-MySQL - 2.9004-3.1.centos4.i386
Resolving for installed requiring package: perl-DBD-MySQL - 
2.9004-3.1.centos4.i386
Resolving for requirement: libmysqlclient.so.14
Needed Require is not a package name. Looking up: libmysqlclient.so.14
Potential Provider: mysql.i386 0:4.1.22-2.el4
Mode is u for provider of libmysqlclient.so.14: mysql.i386 0:4.1.22-2.el4
Mode for pkg providing libmysqlclient.so.14: u
Cannot find an update path for dep for: libmysqlclient.so.14
Searching pkgSack for dep: libmysqlclient.so.14
Potential match for libmysqlclient.so.14 from mysql - 4.1.22-2.el4_8.3.i386
Matched mysql - 4.1.22-2.el4_8.3.i386 to require for libmysqlclient.so.14
Potential match for libmysqlclient.so.14 from mysql - 4.1.22-2.el4.i386
Matched mysql - 4.1.22-2.el4.i386 to require for libmysqlclient.so.14
mysql - 4.1.22-2.el4.i386 is in providing packages but it is already 
installed, removing.
Potential resolving package mysql - 4.1.22-2.el4_8.3.i386 has newer 
instance in ts.

Dep Number: 3/6
mod_auth_mysql requires: libmysqlclient.so.14
--> Processing Dependency: libmysqlclient.so.14 for package: mod_auth_mysql
Calling rpmdb.returnHeaderByTuple on mod_auth_mysql.i386 1:2.6.1-2.2
Requiring package is installed: mod_auth_mysql - 1:2.6.1-2.2.i386
Resolving for installed requiring package: mod_auth_mysql - 1:2.6.1-2.2.i386
Resolving for requirement: libmysqlclient.so.14
Needed Require has already been looked up, cheating
Potential Provider: mysql.i386 0:4.1.22-2.el4
Mode is u for provider of libmysqlclient.so.14: mysql.i386 0:4.1.22-2.el4
Mode for pkg providing libmysqlclient.so.14: u
Cannot find an update path for dep for: libmysqlclient.so.14
Searching pkgSack for dep: libmysqlclient.so.14
Potential match for libmysqlclient.so.14 from mysql - 4.1.22-2.el4_8.3.i386
Matched mysql - 4.1.22-2.el4_8.3.i386 to require for libmysqlclient.so.14
Potential match for libmysqlclient.so.14 from mysql - 4.1.22-2.el4.i386
Matched mysql - 4.1.22-2.el4.i386 to require for libmysqlclient.so.14
mysql - 4.1.22-2.el4.i386 is in providing packages but it is already 
installed, removing.
Potential resolving package mysql - 4.1.22-2.el4_8.3.i386 has newer 
instance in ts.

Dep Number: 4/6
MySQL-python requires: libmysqlclient_r.so.14
--> Processing Dependency: libmysqlclient_r.so.14 for package: MySQL-python
Calling rpmdb.returnHeaderByTuple on MySQL-python.i386 0:1.2.1_p2-1.el4.1
Requiring package is installed: MySQL-python - 1.2.1_p2-1.el4.1.i386
Resolving for installed requiring package: MySQL-python - 
1.2.1_p2-1.el4.1.i386
Resolving for requirement: libmysqlclient_r.so.14
Needed Require is not a package name. Looking up: libmysqlclient_r.so.14
Potential Provider: mysql.i386 0:4.1.22-2.el4
Mode is u for provider of libmysqlclient_r.so.14: mysql.i386 0:4.1.22-2.el4
Mode for pkg providing libmysqlclient_r.so.14: u
Cannot find an update path for dep for: libmysqlclient_r.so.14
Searching pkgSack for dep: libmysqlclient_r.so.14
Potential match for libmysqlclient_r.so.14 from mysql - 
4.1.22-2.el4_8.3.i386
Matched mysql - 4.1.22-2.el4_8.3.i386 to require for libmysqlclient_r.so.14
Potential match for libmysqlclient_r.so.14 from mysql - 4.1.22-2.el4.i386
Matched mysql - 4.1.22-2.el4.i386 to require for libmysqlclient_r.so.14
mysql - 4.1.22-2.el4.i386 is in providing packages but it is already 
installed, removing.
Potential resolving package mysql - 4.1.22-2.el4_8.3.i386 has newer 
instance in ts.

Dep Number: 5/6
MySQL-python requires: libmysqlclient_r.so.14(libmysqlclient_14)
--> Processing Dependency: libmysqlclient_r.so.14(libmysqlclient_14) for 
package: MySQL-python
Calling rpmdb.returnHeaderByTuple on MySQL-python.i386 0:1.2.1_p2-1.el4.1
Requiring package is installed: MySQL-python - 1.2.1_p2-1.el4.1.i386
Resolving for installed requiring package: MySQL-python - 
1.2.1_p2-1.el4.1.i386
Resolving for requirement: libmysqlclient_r.so.14(libmysqlclient_14)
Needed Require is not a package name. Looking up: 
libmysqlclient_r.so.14(libmysqlclient_14)
Potential Provider: mysql.i386 0:4.1.22-2.el4
Mode is u for provider of libmysqlclient_r.so.14(libmysqlclient_14): 
mysql.i386 0:4.1.22-2.el4
Mode for pkg providing libmysqlclient_r.so.14(libmysqlclient_14): u
Cannot find an update path for dep for: 
libmysqlclient_r.so.14(libmysqlclient_14)
Searching pkgSack for dep: libmysqlclient_r.so.14(libmysqlclient_14)
Potential match for libmysqlclient_r.so.14(libmysqlclient_14) from mysql 
- 4.1.22-2.el4_8.3.i386
Matched mysql - 4.1.22-2.el4_8.3.i386 to require for 
libmysqlclient_r.so.14(libmysqlclient_14)
Potential match for libmysqlclient_r.so.14(libmysqlclient_14) from mysql 
- 4.1.22-2.el4.i386
Matched mysql - 4.1.22-2.el4.i386 to require for 
libmysqlclient_r.so.14(libmysqlclient_14)
mysql - 4.1.22-2.el4.i386 is in providing packages but it is already 
installed, removing.
Potential resolving package mysql - 4.1.22-2.el4_8.3.i386 has newer 
instance in ts.

Dep Number: 6/6
dovecot requires: libmysqlclient.so.14
--> Processing Dependency: libmysqlclient.so.14 for package: dovecot
Calling rpmdb.returnHeaderByTuple on dovecot.i386 0:0.99.11-9.EL4
Requiring package is installed: dovecot - 0.99.11-9.EL4.i386
Resolving for installed requiring package: dovecot - 0.99.11-9.EL4.i386
Resolving for requirement: libmysqlclient.so.14
Needed Require has already been looked up, cheating
Potential Provider: mysql.i386 0:4.1.22-2.el4
Mode is u for provider of libmysqlclient.so.14: mysql.i386 0:4.1.22-2.el4
Mode for pkg providing libmysqlclient.so.14: u
Cannot find an update path for dep for: libmysqlclient.so.14
Searching pkgSack for dep: libmysqlclient.so.14
Potential match for libmysqlclient.so.14 from mysql - 4.1.22-2.el4_8.3.i386
Matched mysql - 4.1.22-2.el4_8.3.i386 to require for libmysqlclient.so.14
Potential match for libmysqlclient.so.14 from mysql - 4.1.22-2.el4.i386
Matched mysql - 4.1.22-2.el4.i386 to require for libmysqlclient.so.14
mysql - 4.1.22-2.el4.i386 is in providing packages but it is already 
installed, removing.
Potential resolving package mysql - 4.1.22-2.el4_8.3.i386 has newer 
instance in ts.
miss = 12
conf = 0
CheckDeps = 0
--> Finished Dependency Resolution
Dependency Process ending
Error: Missing Dependency: libmysqlclient_r.so.14 is needed by package 
MySQL-python
Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is 
needed by package dovecot
Error: Missing Dependency: libmysqlclient.so.14 is needed by package dovecot
Error: Missing Dependency: libmysqlclient.so.14 is needed by package 
perl-DBD-MySQL
Error: Missing Dependency: libmysqlclient.so.14 is needed by package 
mod_auth_mysql
Error: Missing Dependency: libmysqlclient_r.so.14(libmysqlclient_14) is 
needed by package MySQL-python
[root at centos4 hello]# find / -name newsletter_20080514.html



On 3/10/2010 1:23 PM, Karanbir Singh wrote:
> On 03/10/2010 06:54 PM, Todd Cary wrote:
>    
>> -->   Processing Dependency: libmysqlclient.so.14 for package: dovecot
>> -->   Finished Dependency Resolution
>> Error: Missing Dependency: libmysqlclient_r.so.14 is needed by package
>> MySQL-python
>>      
>
> what mysql do you have installed on this machine ?
>
> also, running yum with -d8 will tell you exactly what is going on, and
> why the packages cant be found. try that, if its still confusing - put
> that on a pastebin and post the url to that here ( make sure you put the
> whole output on the pastebin, and none here )
>
> - KB
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>
>
>    

-- 
Ariste Software
Petaluma, CA 94952

http://www.toddcary.com/aristephotography/



More information about the CentOS mailing list