[CentOS] updating to gtk+ >= 2.0

Niki Kovacs contact at kikinovak.net
Mon Nov 15 01:16:19 EST 2010


aurfalien at gmail.com a écrit :

> 
> Funny thing is those are already installed.
> 
> However I require a later version of gtk+.
> 

[kikinovak at babasse:~] $ rpm -qa | grep ^gtk
...
gtk2-2.10.4-20.el5
gtk2-engines-2.8.0-3.el5
gtk+-1.2.10-56.el5
...

GTK (Gimp Tool Kit) is a graphic library originally designed for Gimp, 
and needed by a series of graphical applications.

GTK1 (gtk+-1.2.10) is the old version of GTK, needed by GTK1 
applications like XMMS, for example, with all those grey and unsexy menus.

As for the gtk2-2.10.4 package, it's one of those packages that are 
really behind in CentOS. The consequence of that is for example that 
GIMP can't be offered in a version greater than 2.2.

My advice : wait for CentOS 6.0 with a more recent GTK2.

Cheers,

Niki


More information about the CentOS mailing list