[CentOS] cannot install glibc.i686 on x86_64

Kai Schaetzl maillists at conactive.com
Fri Nov 23 12:46:53 UTC 2012


Johnny Hughes wrote on Thu, 22 Nov 2012 20:11:17 -0600:

Thank you both for the replies.
This was my own mistake combined with some depsolving weirdness of yum.

I have 386 and 686 excluded from the repo's because of the greediness to 
install all versions of a package. At least in earlier versions of the 5.x 
series.

When I first hit the error I checked and commented out the line. But there 
was no change with the error. I looked on mirror.centos.org and there was 
no glibc-common.i686. (Didn't look in updates then, but did now, there's 
really none.)

My mistake was that I commented out the exclude for the base repo, but not 
for updates. After commenting out for updates there is no problem to get 
glibc.i686. And it doesn't ask for glibc-common.

Seems there is a dependency in the i686 package that is resolved by the 
x86_64 package of glibc-common, but as I was accidentally trying to 
install an older version of glibc.i686 the installed newer version didn't 
match.



Kai




More information about the CentOS mailing list