[Arm-dev] [arm-dev] Gigabyte MP30-AR0

Gordan Bobic gordan at redsleeve.org
Sun Apr 24 09:09:51 UTC 2016

On 24/04/16 01:18, Ronald Maas wrote:
> No luck with any PCIe adapter on Centos 7.2
> 1) SIIG SATA crashes Tianocore when I connect it to a hard drive
> http://pastebin.com/yDu3mcCK

I haven't tried a Marvell based add-in card myself as I don't have one 
lying around, but I have tried Silicon Image 3132 SATA and 3ware 9650SE 
SAS. They both crash only when I load the kernel driver, they all made 
it past the Tianocore UEFI boot (chain-loaded from u-boot - are you 
booting directly into Tianocore?)

It is worth noting that I managed to get it to not crash when using the 
CentOS supplied 4.2.0 kernel, but with a mainline 4.4.6 it panics the 
kernel due to, IIRC, an unaligned access error. Here is the kernel I used:


There is 4.4.8 in the same folder, but I haven't tried that with PCIe 
cards yet as the machine moved from my test bench into production.

> 2) Radeon 290X caused kernel panic on boot when using Marcin's
> xorg.conf and kernel patch. I tried compiling the radeon driver as
> module and as built-in, but that made no difference
> http://pastebin.com/be4ucvfk
> 3) nVidia GT70 is not recognized by X even when using Marcin xorg.conf
> + kernel patch.Compiling nouveau driver as module or built-in made no
> difference. Both X -configure and startx returned an error every time
> I tried http://pastebin.com/q5ANbtp5 http://pastebin.com/XigAJ6zk

Does the kernel nouveau driver load?

> In all 3 cases lspci recognized the PCIe adapter http://pastebin.com/EYAErr57

Given that we are seeing kernel panics with different SATA, SAS, AMD and 
Nvidia cards, the only thing I can conclude is that there is a major bug 
somewhere in the PCIe driver. The main difference between my kernel 
4.4.x kernels and the CentOS 4.2.0 is that the latter uses 64KB memory 
pages, so that is probably a good place to start looking.


More information about the Arm-dev mailing list