[Arm-dev] Qemu Arm Emulator in CentOS host(x86)

karthi mohanraj karthimohanraj.in at gmail.com
Wed Oct 17 13:47:25 UTC 2018


Hi All, 

I’m trying to install fedora on QEMU emulator for the ARM. I have followed this documentation using virt-manager in this link: 

https://fedoraproject.org/wiki/Architectures/ARM/F26/Installation#For_Versatile_Express_Emulation_with_QEMU <https://fedoraproject.org/wiki/Architectures/ARM/F26/Installation#For_Versatile_Express_Emulation_with_QEMU>


I was getting USB PCI device error as below.


2018-10-17 12:18:35.914+0000: starting up libvirt version: 3.9.0, package: 14.el7_5.8 (CentOS BuildSystem <http://bugs.centos.org <http://bugs.centos.org/>>, 2018-09-26-18:30:11, x86-01.bsys.centos.org <http://x86-01.bsys.centos.org/>), qemu version: 2.0.0, hostname: localhost.localdomain
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-system-arm -name guest=fedora22-arm,debug-threads=on -S -machine virt,accel=tcg,usb=off,dump-guest-core=off -m 2048 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid fc26e72b-3aaa-407b-a4fa-8896bbb8c580 -display none -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-30-fedora22-arm/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot strict=on -kernel /var/lib/libvirt/images/arm/vmlinuz-4.8.6-300.fc25.armv7hl -initrd /var/lib/libvirt/images/arm/initramfs-4.8.6-300.fc25.armv7hl.img -append 'console=ttyAMA0 rw root=LABEL=_/ rootwait' -device ich9-usb-ehci1,id=usb -device ich9-usb-uhci1,masterbus=usb.0,firstport=0 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4 -device virtio-scsi-device,id=scsi0 -device virtio-serial-device,id=virtio-serial0 -drive file=/var/lib/libvirt/images/arm/Fedora-Minimal-armhfp-25-1.3-sda.raw,format=raw,if=none,id=drive-scsi0-0-0-0 -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 -netdev tap,fd=27,id=hostnet0 -device virtio-net-device,netdev=hostnet0,id=net0,mac=52:54:00:46:70:cb -chardev pty,id=charserial0 -serial chardev:charserial0 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channel/target/domain-30-fedora22-arm/org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.qemu.guest_agent.0 -object rng-random,id=objrng0,filename=/dev/urandom -device virtio-rng-device,rng=objrng0,id=rng0 -msg timestamp=on

(process:12978): GLib-WARNING **: gmem.c:483: custom memory allocation vtable not supported
char device redirected to /dev/pts/2 (label charserial0)
2018-10-17T12:18:36.052249Z qemu-system-arm: -device ich9-usb-ehci1,id=usb: No 'PCI' bus found for device 'ich9-usb-ehci1'
2018-10-17 12:18:36.282+0000: shutting down, reason=failed


Thanks,
Karthi 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/arm-dev/attachments/20181017/9e215b27/attachment.html>


More information about the Arm-dev mailing list