[CentOS-devel] Anaconda errors when building custom CentOS-based distro

Fri May 6 13:56:50 UTC 2005
Sam Hart <sam at progeny.com>

On Thu, 2005-05-05 at 19:37 -0500, Johnny Hughes wrote:
> > Removing unused python files in hdimage... /usr/sbin/chroot: cannot run command `/usr/bin/anaconda': No such file or directory
> One thing I notice is that I have to run genhdlist twice ... the guide
> only does it once.  Here is the appropriate part of my build script:

genhdlist twice with the pkgorder is a very good idea... (and your
script is much more concise than other anaconda wrapper scripts that I
have worked with, so I may just start using it instead ;-)

> Other issues I have had:
> When making from a new tree (where there are no
> $DISTDIR/$ARCH/CentOS/base) ... touch these files in
> $DISTDIR/$ARCH/CentOS/base (before running
> genhdlist/pkgorder/buildinstall):
> hdlist  hdlist2  hdstg2.img  netstg2.img  stage2.img
> and
> also touch $DISTDIR/$ARCH/.discinfo
> buildinstall has to be run as root

Unfortunately, none of these issues solved the issue. I still get
'/usr/bin/anaconda' not found errors.

I'm about to give up and dive into the anaconda-runtime to see where
this file precisely is supposed to get copied over so I can maybe add
excessive debugging statements to see why it isn't.

.O.                                         Sam Hart, sam at progeny.com
..O                                        Progeny Linux Systems, Inc
OOO                                         <http://www.progeny.com/>