[CentOS-devel] Anaconda errors when building custom CentOS-based distro

Fri May 6 14:53:29 UTC 2005
Sam Hart <sam at progeny.com>

On Fri, 2005-05-06 at 09:25 -0500, Johnny Hughes wrote:
> On Fri, 2005-05-06 at 08:56 -0500, Sam Hart wrote:
> <snip>
> > Unfortunately, none of these issues solved the issue. I still get
> > '/usr/bin/anaconda' not found errors.
> > 
> > I'm about to give up and dive into the anaconda-runtime to see where
> > this file precisely is supposed to get copied over so I can maybe add
> > excessive debugging statements to see why it isn't.
> > 
> Are you building from within chroot?  I build RPMS in chroots, but I
> haven't tried to actually run buildinstall from within one.
> Buildinstall does it's own chroot while building ... so I don't know how
> well it would run from within a chroot itself. (It might work fine ... I
> just haven't tried it).

Yes, I have been building all my ISOs from within chroots. If
buildinstall has any conflicts with this, this will be the first time I
have encountered it.

In fact, as a double-check I have rebuilt the other ISOs I've built
before (two FC2-based, one a mix of FC3/2) inside this exact build
environment and they built successfully.

I'm also wondering if perhaps I am missing a package that might have a
soft-dependency (e.g., a dependency that, for whatever reason, isn't
explicitly defined and thus not checkable using my dep closure scripts).
If this is the case however, nothing in the output alludes to what it
could be.

What I'm doing now is stopping the script (upd-instroot, which seems to
be where the problem is) when it gets the missing anaconda error. As
soon as I can track down exactly what it was trying to do during that
error, I can trace back to where /usr/bin/anaconda is being lost.

.O.                                         Sam Hart, sam at progeny.com
..O                                        Progeny Linux Systems, Inc
OOO                                         <http://www.progeny.com/>