[CentOS-devel] RPMS and REPOS and REPO-Linkages

Kevan Benson kbenson at a-1networks.com
Sat Nov 18 00:42:28 UTC 2006

On Friday 17 November 2006 15:09, Greg Swallow wrote:
> You have to consider upstream, because they aren't going to add
> "Obsoletes: php5" to their php packages.
> My only concern with php-5.1.6 in centosplus is that RHEL5-beta1 is
> currently using 5.1.4.  Sure it's just beta1 and it may change, but if
> it doesn't that will make for a slightly trickier upgrade for some
> people at some point in the future.  For example the RHWAS php rpm is
> newer than the RHEL5-beta1 rpm but has a lower version# (5.1.4-1 vs
> 5.1.4-8).  I am sure that is intentional so an upgrade to RHEL5 upgrades
> php.

Good point.  Unless you want to muck with all the core spec files to change 
that, it means installing php from the base would result in two package sets.  
Does anyone know how RHWAS deals with this?  I guess it's actually a 
non-issue for them, as their whole application stack repo is probably meant 
to be installed together, not in portions (as with centosplus).

- Kevan Benson
- A-1 Networks

More information about the CentOS-devel mailing list