[CentOS-devel] We need a newer Vagrant in SCL

Michael Vermaes mvermaes at gmail.com
Tue May 2 16:03:10 UTC 2017

On Tue, May 2, 2017 at 11:06 PM, Laurentiu Pancescu <lpancescu at gmail.com> wrote:
> On 02/05/17 13:13, Pavel Valena wrote:
>>> On 25/04/17 13:38, Laurentiu Pancescu wrote:
>>> I changed the test to use the upstream versions of Vagrant and
>>> vagrant-libvirt (we already used the VirtualBox packages from Oracle).
>>> Vagrant 1.9.4, the newest release, doesn't recognize vagrant-libvirt, so
>>> the test fails - I'm using Vagrant 1.9.3 for the time being, that
>>> version works.
>> I am working on the sclo-vagrant1 SCL update. Thanks for the heads-up
>> regarding the vagrant version usability. I will push to testing the new SCL
>> builds ASAP(ETA < 1 month)
> It seems a bit more nuanced than I thought: upstream vagrant-libvirt only
> supports Vagrant 1.5 to 1.8. [1]  There's also a table with build failures
> on Vagrant 1.9.1 if you scroll up.  For some reason, 1.9.3 worked on CentOS
> Linux 7 with vagrant-libvirt and 1.9.4 didn't, but 1.9.x is clearly not a
> supported configuration - not yet.

Regarding this specific point, I think it is maybe more likely a
documentation oversight that they haven't updated that reference to
include 1.9+. The continuation of the line mentioning supported
versions says "We only test with the upstream version! If you decide
to install your distros version and you run into problems, as a first
step you should switch to upstream." The lead contributor also seems
to have closed an issue against the 'latest' vagrant on CentOS 7 a few
days ago [1].

Just thought I'd mention it, but I agree that the compatibility table
suggests the earlier versions would be more stable. Additionally, I
don't use libvirt anyway, so I will be quiet now :)

[1] https://github.com/vagrant-libvirt/vagrant-libvirt/issues/772

More information about the CentOS-devel mailing list