[CentOS-devel] EVP_sha1() returning exception invalid digest in fips mode on Centos7.4

Trevor Hemsley trevor.hemsley at ntlworld.com
Tue Apr 10 12:09:44 UTC 2018

On 10/04/18 13:07, Veetil, Vyshnav wrote:
> Hi,
> We are facing an issue when we are trying to sign a certificate using
> digest value EVP_sha1(). It throws an exception error
> “Error: com.adharman.datatools.DataException: java.lang.Exception:
> java.lang.Exception: [0x80004005] AvMiuOpenSSLCertCreate,
> X509_sign->0. [error:060B7098:digital envelope
> routines:EVP_DigestSignInit:invalid digest]”
> When I tried same thing with EVP_sha256() it worked. Is there any
> change in Centos7.4? Any deprecation for sha1? 
> Please share your thoughts on the same.

The exact same question asked on the forums gets the exact same answer:

7.4 deprecated SHA1 - see the upstream release notes.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-devel/attachments/20180410/615b6a29/attachment.html>

More information about the CentOS-devel mailing list