[CentOS-devel] Reboot issue with kernel 3.10.0-862.el7.x86_64

Lamar Owen lowen at pari.edu
Mon Apr 30 12:51:18 UTC 2018


Ok, so I'm trying out CR for 7.5.1804, and I have upgrade three machines 
with it.  One is my laptop, a Dell Precision M6700, which worked fine.  
Another is a Dell R715 server, and that worked fine. The third machine 
will not successfully reboot with the 3.10.0-862.el7.x86_64 kernel, 
throwing endless errors of the form "qla2xxx [0000:03:07.0]-5046:4: 
Async-gpdb failed - hdX-xxx portid=xxxxxx status=38 mb1=0 mb2=0 mb6=0 
mb7" (that's as long as the line is on the screen, and it's not recorded 
into /var/log/messages (and C7 by default doesn't implement persistent 
journal storage; journalctl --list-boots only lists the current boot log)).

System is a bit old, but is only used for development: Dell PowerEdge 
SC1425 two single-core Xeon 3.2GHz (obviously 64-bit capable, as it is 
running stock CentOS 7 already, with kernel 3.10.0-693.21.1.el7.x86_64 
running fine.  System is connected to two EMC Clariion arrays via a 
dual-port Fibre-Channel card: lspci tells me:
03:07.0 Fibre Channel: QLogic Corp. ISP2312-based 2Gb Fibre Channel to 
PCI-X HBA (rev 02)
03:07.1 Fibre Channel: QLogic Corp. ISP2312-based 2Gb Fibre Channel to 
PCI-X HBA (rev 02)

Yeah, I know, not new, and maybe even deprecated (I actually don't see 
that adapter in the deprecated list for RHEL 7.5, but I do see ISP24xx 
ones in the deprecated list), but it worked fine with the 7.4.1708 
kernel.  I set the system to boot the older kernel until I can more 
fully troubleshoot.  I have a lot invested in ISP24xx-based cards, which 
are on the deprecated list, and I am still running fibre-channel, so 
will have to find another solution before 7.x EOL.

So I consider this a regression; for the moment I'll boot the older 
kernel, but I know that isn't sustainable.



More information about the CentOS-devel mailing list