[CentOS-docs] Translation of centos-art.sh script

Sat Sep 8 16:39:06 UTC 2012
Akemi Yagi <amyagi at gmail.com>

On Sat, Sep 8, 2012 at 7:19 AM, Alain Reguera Delgado
<alain.reguera at gmail.com> wrote:
> On 09/07/2012 09:25 PM, Akemi Yagi wrote:
>> I ran 'centos-art.sh prepare' but it kept going and I finally gave up
>> after 10 hrs or so and had to kill it.
> Kept going in which way, please? It should take no longer than 30
> minutes in the worst of cases. Could you provide some output, error,
> anything else that could help me to determine in which point it is
> taking that abnormal time long.
> Notice that I've committed some updates to the preparation scripts
> recently so it would be a good idea to update your working copy and try
> again. For doing this run the following command:
> svn update ${HOME}/artwork/trunk/Scripts/Bash
>> Is there an easier way of
>> providing translations? If there are a set of words / phrases that
>> need to be translated, can you just collect them and use?
> Yes, that's exactly what the script does for me and for all the
> translators. Please, don't give up yet, it is too soon :). Let's give it
> another try to find out why the `centos-art.sh' script isn't working for
> you.

I used another VM running the .ja version of CentOS-6 and did it from
scratch. I ran 'centos-art.sh prepare' in a verbose mode. It ran
through instantly till the end of init.sh and then would not go any
further at this step:

# init.sh -- This function initiates the application's command-line
# interface.  Variables defined in this function are accesible by all
# other functions. The cli function is the first script executed by
# the application command-line onces invoked.
function init {
grep '^function ' ${FILE} | cut -d' ' -f2)
grep '^function ' ${FILE} | cut -d' ' -f2)
grep '^function ' ${FILE} | cut -d' ' -f2
echo $ARG | sed "s/'/\\\0x27/g")
echo $ARG | sed "s/'/\\\0x27/g"

It is using cpu at 30-40% and I see :

2234 pts/0    S+    24:35 /bin/bash
/home/yagi2/artwork/trunk/Scripts/Bash/centos-art.sh help

Hope this info helps you identify the problem.