[CentOS-virt] VMware Server clock woes (running too fast)

Fri Aug 22 02:28:00 UTC 2008
Michael Ekstrand <michael at elehack.net>

Pasi Kärkkäinen <pasik at iki.fi> writes:
> On Wed, Aug 20, 2008 at 07:37:25AM -0500, Michael Ekstrand wrote:
>> "Akemi Yagi" <amyagi at gmail.com> writes:
>> > On Tue, Aug 19, 2008 at 5:55 PM, Michael Ekstrand <michael at elehack.net> wrote:
>> >> I'm running VMware Server 1.0.6 on a CentOS 5.2 host and am having some
>> >> clock difficulties.
>> >>
>> >> Host OS is x86_64 running on 1.9 GHz AMD Sempron, nVidia chipset.
>> >>
>> >> Guest OS's are 32-bit FreeBSD (clock works fine after disabling ACPI,
>> >> setting the clock source to the PIT, and running the guest tools), WinXP
>> >> (unknown clock status), and i686 CentOS 5.2 (here is the problem).
>> >>
>> >> I've tried pretty much everything to try to fix it.  I have host.cpukHz,
>> >> host.noTSC, and ptsc.noTSC set in /etc/vmware/config.  I've booted my
>> >> kernel with noapic, nosmp, noacpi, divider=10.  Sadly, I hit the
>> >> clocksource=pit with divider bug, so I have not been able to boot with
>> >> both that and divider=10, although clocksource=pit without a divider
>> >> also does not work.  I even built a custom kernel with SMP and APIC
>> >> disabled, CPU_HZ=100, and booted with clocksource=pit noacpi, and it
>> >> also gains time.
>> >>
>> >> Could anyone provide a recommendation as to what I can do to fix this problem?
>> >
>> > I understand you built a 100Hz kernel, but *just in case*, you might
>> > want to try CentOS-supplied 100Hz kernel (kernel-vm) available from:
>> >
>> > http://people.centos.org/tru/kernel-vm/
>> Just tried it, and it doesn't seem to work. I used the following
>> parameters:
>>  nosmp noapic nolapic noacpi clocksource=pit
> IIRC clocksource=pit should not be used on modern kernels.. 
> Can you try clocksource=acpi_pm ? with tools.synctime = "true" flag in your
> vmx file.
> (if it's available in your kernel).

I tried, and the clock still gains time.  Just took a few minutes for it
to gain a second or two.  I'll try disabling host power management
sometime here when I feel like rebooting.

- Michael

mouse, n: A device for pointing at the xterm in which you want to type.
Confused by the strange files?  I cryptographically sign my messages.
For more information see <http://www.elehack.net/resources/gpg>.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20080821/b1c6cb1f/attachment-0004.sig>