[CentOS-virt] scripted virt-install fails

Thu May 28 18:06:55 UTC 2009
Maros Timko <timkom at gmail.com>

I was experiencing stalling of CentOS5 VMs boot process on HAL daemon. But
only when checking the output of the console from:
xm console <DomU>
Sshing to the DomU worked just fine. If you have sshd running, try to ssh to


2009/5/28 <lists at zfobjects.com>

> I have successfully installed several CentOS 5 VMs on a CentOS 5 Xen
> DOM0 using a local repo and kickstart files with Virt Manager.
> Using the same machine and setup, I have tried a scripted install
> using same repos and kickstart file with virt-install. The only
> difference I can see is that with virt-install I'm disabling the
> display (no VNC).
> The install goes well but the new VM won't finish booting, it keeps
> stalling at various things. So far I have disabled smartd and
> microcode_ctl in kickstart postinstall script, now it is stalling at
> HAL.
> Rather than keep disabling services and retrying, I think it's time to
> ask here what I'm doing wrong ... why does basically the same VM
> install work with Virt Manager but not with virt-install?
>     Thanks
> _______________________________________________
> CentOS-virt mailing list
> CentOS-virt at centos.org
> http://lists.centos.org/mailman/listinfo/centos-virt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20090528/16e4cf86/attachment-0005.html>