[CentOS-virt] VNC not connecting

Tue Oct 20 18:35:59 UTC 2009
Neil Aggarwal <neil at JAMMConsulting.com>

Hello all:

I am trying to install CentOS 5.4 as a KVM guest.
The host is running CentOS 5.4 and does not have
X installed.

I used ssh to connect to the host and ran this command
(I formatted it for readability, it is all on one line):

virt-install -n jamm12e -r 1024 --vcpus=1 --check-cpu 
  --os-type=linux --os-variant=rhel5 --hvm --accelerate 
  -f /usr/local/virt/jamm12e.img -s 20 -b br0 
  --vnc --vncport=5903

When I do that, I get this error:

(virt-viewer:3083): Gtk-WARNING **: cannot open display:
Domain installation still in progress. You can reconnect to
the console to complete the installation process.

I did not expect the installation to try connect to
the display since I told it to use VNC.

Next, I tried to connect TightVNC viewer from my
Windows XP laptop.  I entered
as the server and tried to connect, but that failed.

Did I miss something in the VNC configuration?
I don't see any other parameters to use.


Neil Aggarwal, (281)846-8957, www.JAMMConsulting.com
Will your e-commerce site go offline if you have
a DB server failure, fiber cut, flood, fire, or other disaster?
If so, ask about our geographically redundant database system.