[CentOS-virt] domU reboot leaves VM crashing continually

Tue Sep 1 09:08:56 UTC 2009
Robert E. Moser <araw at bellsouth.net>

Hi Everyone,


I installed a fully virtualized VM on my system noted below.  To keep it
simple I made it puppy linux.  It runs as expected, including successful
reboots.  So
 it appears that reboots are broken on my system for
paravirtualized systems.  I seem to recall the test install of windows I did
about a month ago seemed to work also as it was likewise fully virtualized.


Any ideas?



Robert Moser


From: centos-virt-bounces at centos.org [mailto:centos-virt-bounces at centos.org]
On Behalf Of Robert E. Moser
Sent: Saturday, August 29, 2009 5:05 PM
To: centos-virt at centos.org
Subject: [CentOS-virt] domU reboot leaves VM crashing continually




I’m new to xen virtualization on CentOS, but I have been unable to find the
answer to this problem I’m experiencing.  


My setup: AMD quad core (64bit), 8Gb ram.  CentOS 5.3 dom0, CentOS 5.3
domU’s (paravirtualized).  

Dom0 is set up with two NIC’s, the built-in and a PCI card, and I set up xen
bridging on both interfaces.   


My domU’s seem to boot up fine, run fine, and shutdown fine.  However, if I
attempt a reboot operation, they go into a state where they continually
crash on startup.  I have been unable to ascertain why this happens, and I
do not know how to fix it when it does happen.  So, my question is twofold:


1)      How do I get it out of the continual boot/crash cycle?  Xm destroy
doesn’t work, none of the GUI tools work.  So far the only answer has been
rebooting dom0, which is not a good answer L  

2)      Has anyone else seen this/solved this?  Besides being able to
manually fix it from #1 above, it sure would be nice to have it able to
reboot as expected.   


I haven’t worked with any fully virtualized guests yet, but I will try that
pretty soon and see if it evidences the same behavior.  


Uname –a è Linux prathis.localdomain 2.6.18-128.7.1.el5xen #1 SMP Mon Aug 24
09:14:33 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux


Please let me know what additional information would be helpful or what I
can do to facilitate debugging this issue.  


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20090901/3daf4481/attachment-0003.html>