[CentOS-virt] SOLVED! Xen HVM domU won't start since updates to 2.6.18-164.15.1 kernels

Thu Apr 1 03:50:48 UTC 2010
Aaron Clark <ophidian at ophidian.homeip.net>

On 03/30/2010 07:33 AM, Sergio Charpinel Jr. wrote:
> Aaron,
> Seems to be something related to your block device.
> Try this config file:


I just tried this config and it booted fine:
name = "Belldandy"
maxmem = 256
memory = 256
vcpus = 1
builder = "hvm"
kernel = "/usr/lib/xen/boot/hvmloader"
boot = "c"
pae = 1
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
device_model = "/usr/lib64/xen/bin/qemu-dm"
disk = [ "phy:/dev/SystemsVG/Belldandy,hda,w" ]
vif = [ "mac=00:16:3e:29:65:46,bridge=xenbr0,script=vif-bridge" ]
vnc = 1

Attached is the generated virsh xml from the above.

I'm going to tinker with this for a bit to try and figure out what 
difference from the previous config is actually the cause of the issue. 
  I just had the other, formerly working VM, bail with the same symptoms 
once I got this one work.  The workaround is nice but I definitely want 
to isolate this bug now.

Thanks everyone for all the help!

"The goblins are in charge of maintenance?  Why not just set it on fire 
now and call it a day?"
--Whip Tongue, Viashino Technician
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: belldandy.virsh
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20100331/8c6aa473/attachment-0002.ksh>