[CentOS-virt] accesing remote domU vnc console?

Tue Jul 6 01:28:52 UTC 2010
Fernando Gleiser <fergleiser at yahoo.com>

I'm having an strange weird problem while trying to connect to a remote domU 

The VM runs win2k3, I need to connect on the console in order to change its IP 

I log into dom0, find the domU ID:

[root at btreptab01 xen]# virsh list
 Id Name                 State
  0 Domain-0             running
  8 linux                idle
  9 win2k3               running

so I open a new session and tunnel vnc through it:

ssh -L 5907:localhost:5907 root at remoteip

then launch a vnc client

krdc localhost:7

and nothing happens :/

netstat shows the connection as established on both hosts, but I can't get a 
console working, just a blank screen

I tried enabling vncserver on dom0, connecting to it, launching virt-manager and 
trying to attach to it, same result. It shows a "connecting to console" message 
and nothing more....

the dom0 host is in a datacenter many miles away from here, so walking to it and 
working on the server's console is not a practical option

any ideas/help would be greatly apreciated