[CentOS-virt] freebsd as kvm guest

Tue Apr 30 04:35:12 UTC 2013
Bane Ivosev <bane.ivosev at pmf.uns.ac.rs>

hi, at my workplace we have several freebsd 8.2 and 9.0 kvm vm's in
production (ldap, dns and webmail server).

we use virtio drivers and network  performance is very good. there was
one problem for us with kvm & virtio as i already wrote at freebsd
mailing list. suddenly /var/log/message at kvm hosts  start to growing
at very high rate with warnings about some vlan problems.

solution was to use -tso option with ifconfig_vtnetX in rc.conf.

anyway, that's only problem for us with kvm and freebsd.

anyway, linux is still better option if you need performance (block and
io) then freebsd in both cases, vmware and kvm.

we also tried openbsd in vmware and kvm. and that's bad. unfortunately.

ps. yesterday i tried to do freebsd-update -r 9.1-RELEASE upgrade at one
of my production kvm vm. everything went ok but immediately after reboot
i've got kernel panic. something about unsupported cpu. i didn't have
time to investigate where's the problem.

On 04/29/2013 08:34 PM, mattias wrote:
> thanks for the image
> Now lets's see
> -----Ursprungligt meddelande-----
> Från: centos-virt-bounces at centos.org
> [mailto:centos-virt-bounces at centos.org] För Nux!
> Skickat: den 29 april 2013 20:27
> Till: centos-virt at centos.org
> Ämne: Re: [CentOS-virt] freebsd as kvm guest
> On 29.04.2013 18:54, Ilya Ponetayev wrote:
>> I have about ten installations of pfSense 2 in CentOS/KVM as FreeBSD
>> 8.x
>> profile and experience no problems except significant CPU load at 
>> 50-100
>> Mbps stream shaping/routing/filtering (about 50-60% of one Penitum 
>> G630
>> core at 75 MBps), but this is because of e1000 nics emulation (freebsd
>> 8.x in pfsense 2 has no virtio drivers included as I can remember).
> I too wanted to use PFSense on KVM/EL6 but network performance was 
> disappointing. My network engineers reverted to using VMware ESXi for 
> the time being.
> My hope is with Fbsd 10 which includes virtio drivers by default (and 
> also has a SMP friendly PF :> ).
> BTW, here's a QCOW2 of it, import image as RHEL6 profile (has all the 
> virtio stuff):
> http://li.nux.ro/download/openstack/images/fbsd10-snap-20130316-r248381-
> TESTING.qcow2
> The root passwd is "password" so change it ASAP!
> Even with this image I could not saturate 1 Gbps link (just rudimentary 
> test with "fetch -o /dev/null"), but it's still an improvement.