[CentOS-virt] xen-c6 fails to boot

Bob Ball

bob.ball at citrix.com
Thu Dec 4 12:39:00 UTC 2014

Thanks all for the advice.

It seems there is an issue with Dracut booting from these hosts when LVM is used.

dracut: Scanning devices sda2  for LVM logical volumes VolGroup/lv_swap VolGroup/lv_root 
dracut: inactive '/dev/VolGroup/lv_swap' [1.94 GiB] inherit
dracut: inactive '/dev/VolGroup/lv_root' [230.69 GiB] inherit
dracut: PARTIAL MODE. Incomplete logical volumes will be processed.
dracut: Operation prohibited while global/metadata_read_only is set.
dracut: Operation prohibited while global/metadata_read_only is set.
dracut Warning: LVM VolGroup/lv_swap not found
dracut Warning: LVM VolGroup/lv_root not found

Switching my kickstart to use real partitions rather than LVM solved the issue.  Not sure if that's enough detail to figure out what's wrong / missing from the kernel / initrd.


> -----Original Message-----
> From: centos-virt-bounces at centos.org [mailto:centos-virt-
> bounces at centos.org] On Behalf Of Johnny Hughes
> Sent: 04 December 2014 09:51
> To: centos-virt at centos.org
> Subject: Re: [CentOS-virt] xen-c6 fails to boot
> On 12/02/2014 07:36 AM, Bob Ball wrote:
> >> -----Original Message-----
> >> From: Johnny Hughes
> >> On 12/01/2014 04:48 AM, Bob Ball wrote:
> >>>
> >>>  [<ffffffff81575480>] panic+0xc4/0x1e1
> >>>  [<ffffffff81054836>] find_new_reaper+0x176/0x180
> >>>  [<ffffffff81055345>] forget_original_parent+0x45/0x2c0
> >>>  [<ffffffff81107214>] ? task_function_call+0x44/0x50
> >>>  [<ffffffff810555d7>] exit_notify+0x17/0x140
> >>>  [<ffffffff81057053>] do_exit+0x1f3/0x450
> >>>  [<ffffffff81057305>] do_group_exit+0x55/0xd0
> >>>  [<ffffffff81057397>] sys_exit_group+0x17/0x20
> >>>  [<ffffffff815806a9>] system_call_fastpath+0x16/0x1b
> >>
> >> It works fine for me .. you might consider using CentOS-6.6 and not
> >> CentOS-6.4 .. also, we now use a 3.10 kernel and the latest version of
> >> xen is 4.2.5 in the /6.6/xen4/ repo.
> >
> > Updated to CentOS-6.6, but I still get the same issue.
> >
> > By the above I assume you're using the xen4 repo rather than the xen-c6
> repository referred to by http://wiki.centos.org/QaWiki/Xen4?
> > Is the xen-c6 repo now considered broken or deprecated with the xen4
> repo used in preference?
> >
> >> BUT .. it seems to be a hardware/driver issue.
> >
> > The same hardware (cluster of 10 machines) was successfully working with
> the xen-c6 repository previously; I'm not sure what issue might have
> occurred to cause this failure on all hosts which is why I think it's a software
> issue.  Possibly a driver issue although the last successful run was using the
> same kernel so I assume had roughly the same drivers installed.  Note that
> the 3.4 kernel boots fine without Xen, it is only under Xen that the boot fails
> and the machine restarts.
> >
> What I mean by hardware issue is the way the hardware interacts with the
> newer versions of xen.  I guess what I should have said is that there is
> some unique issue with your hardware.
> The updates have have posted are needed for numerous security updates,
> so I would not recommend running older versions long term for security
> reasons ... BUT ... all the previously released software is here:
> http://vault.centos.org/6.4/xen4/
> http://vault.centos.org/6.5/xen4/
> and
> http://mirror.centos.org/centos/6.6/xen4/
> In this unique case (ie, your exact hardware and software combinations),
> you may need to experiment with and find the exact combination of
> software that works for you.
> In any event, all the software we have previously released is in those
> locations, so getting a combination that works so we can isolate the
> issue that causes it all to die is likely the best starting point.

More information about the CentOS-virt mailing list