[Centos] update killed my x

Thu Dec 23 03:23:48 UTC 2004
beau <phaedral at gmail.com>

X server, that is (as opposed to my ex-spouse...)  Anyway, I was
loving life with my rebuilt 2.4.21-9.0.1.EL.c0custom041130a kernel,
and then ran "yum update", which gave me a grub line for
2.4.21-20.0.1EL, but the 21-20 not only won't work with the old X
settings, I can't get it to set up X at all.  I tried running "yum
update" from a console on this kernel, but yum can't find the conf
file unless I tell it where it is with the -c switch, and even then it
won't follow the symlink from /etc/yum.conf to /etc/centos-yum.conf. 
Once I supply the proper switch and path then it starts the update and
chokes on the GPG keys for php-mysql.  As directed in the error
message I've tried running yum clean and also tried removing the
/var/.../php-mysql... file indicated, to no avail.

That said, all helpers appreciated.

Robert Thomas ("beau") Hayes Link
Open your heart, pray for peace, preach healing
(c)2004ISR http://www.semanticrestructuring.com/