[Centos] update killed my x

Thu Dec 23 04:23:03 UTC 2004
seth vidal <skvidal at phy.duke.edu>

On Wed, 2004-12-22 at 19:23 -0800, beau wrote:
> X server, that is (as opposed to my ex-spouse...)  Anyway, I was
> loving life with my rebuilt 2.4.21-9.0.1.EL.c0custom041130a kernel,
> and then ran "yum update", which gave me a grub line for
> 2.4.21-20.0.1EL, but the 21-20 not only won't work with the old X
> settings, I can't get it to set up X at all.  I tried running "yum
> update" from a console on this kernel, but yum can't find the conf
> file unless I tell it where it is with the -c switch, and even then it
> won't follow the symlink from /etc/yum.conf to /etc/centos-yum.conf. 
> Once I supply the proper switch and path then it starts the update and
> chokes on the GPG keys for php-mysql.  As directed in the error
> message I've tried running yum clean and also tried removing the
> /var/.../php-mysql... file indicated, to no avail.

1. I just verified all the php* packages in updates for both 3.3 and 3.1
i386. They all check out fine.
2. What specific error messages are you getting? Can you cut and paste
them? It makes debugging much simpler.
3. output of ls -la /etc/yum.conf shows what?
4. why had you rebuilt your kernel before? Do you have an odd video card
that needed some special love from the kernel?