Getting kernel panic when installer starts formatting partitions. Was: [Centos] How to get 3Ware 9500S controller card working in CentOS 3.1?

Fri Jul 16 15:49:53 UTC 2004
Sean Staats <sstaats at>

*What I'm trying to do:
Install CentOS 3.1 to a RAID 5 array consisting of 4 drives attached to
a 3ware 9500S-4LP which will be the boot device.

*Error I'm getting (when installer tries formatting a partition):
Code: 0f 0b 2b 01 10 b2 24 c0 58 5a eb fe 89 f6 8a 54 24 04 8d 42
Kernel panic: Fatal exception
In interrupt handler - not syncing

*Hardware specs:
Supermicro SuperServer 6013P-T with 2 2.6GHz Xeon CPUS, 4GB RAM, and 4
250GB Western Digital SATA drives attached to a 3ware 9500S-4LP in RAID
5 mode.

*What I've done so far:
I've successfully created a driver disk in that the installation utility
successfully loads the 3w-9xxx driver module and continues the install
process.  I am then able to create partitions on the array.  But once
the installation utility starts formatting the first partition, the
kernel panics with the following message:
Code: 0f 0b 2b 01 10 b2 24 c0 58 5a eb fe 89 f6 8a 54 24 04 8d 42
Kernel panic: Fatal exception
In interrupt handler - not syncing

Here are the steps I followed to try to install the OS:
*Note - steps 1-6 were all done on a stock CentOS 3.1 system without a
3ware card.

1) Download the following files from
ws3__x86.tgz (Install disk files)
3w-9xxx.tgz (Linux 2.4 Kernel Driver Source)

2) Create installation driver disk:
Format a 3.5 inch floppy(with msdos filesystem)
mount /mnt/floppy
tar xzf ws3__x86.tgz -C /mnt/floppy

3) Compile the 3w-9xxx driver (i686):
tar xzf 3w-9xxx.tgz
cd driver
make -f Makefile.rh
make smp -f Makefile.rh
make bot -f Makefile.rh
make hug -f Makefile.rh
cd ..

4) Create directories and copy in compiled drivers:
mkdir modules
cd modules
mkdir 2.4.21-9.0.1.EL.c0
cp ../driver/3w-9xxx.o 2.4.21-9.0.1.EL.c0/3w-9xxx.o
mkdir 2.4.21-9.0.1.EL.c0BOOT
cp ../driver/ 2.4.21-9.0.1.EL.c0BOOT/3w-9xxx.o
mkdir 2.4.21-9.0.1.EL.c0hugemem
cp ../driver/3w-9xxx.hug 2.4.21-9.0.1.EL.c0hugemem/3w-9xxx.o
mkdir 2.4.21-9.0.1.EL.c0smp
cp ../driver/3w-9xxx.smp 2.4.21-9.0.1.EL.c0smp/3w-9xxx.o

5) Create a new modules.cgz file (replacing one on floppy):
find . -depth | cpio -o -H newc | gzip -c > /mnt/floppy/modules.cgz

6) Unmount floppy disk:
umount /mnt/floppy

7) Use the new driver disk when installing CentOS 3.1:
At the installation linux boot prompt type 'linux dd'

Then from there, have the installation utility use the driver floppy,
and continue with the installation.  One can create partitions on the
array, but the kernel panics when trying to format the first partition.

I've verified that Windows XP does install on the same machine.  So I
don't think there are any hardware incompatibilities.  

Any insight and help to resolve this is greatly appreciated.


On Fri, 2004-07-09 at 07:42, centos-admin at wrote:
> Looking at the 3ware driver disk here is the content
> zcat modules.cgz | cpio -ivd
> 2.4.21-4.EL/3w-9xxx.o
> 2.4.21-4.ELBOOT/3w-9xxx.o
> 2.4.21-4.ELhugemem/3w-9xxx.o
> 2.4.21-4.ELsmp/3w-9xxx.o
> notice... no i386 directory
> Plus...the only i386 kernel is the BOOT kernel...please build the 
> correct driver for i686 or athlon...depending on your system
> modinfo
> modules.cgz
> modules.dep
> pcitable
> rhdd-6.1
> src/
> src/2.4/
> src/2.4/3w-9xxx.tgz
> Try using the the driver disk from 3ware replacing the modules.cgz.
> DP
> Sean Staats wrote:
> >My goal is to be able to install to the drive array on the 3Ware
> >controller card.  3Ware does provide a RH WS 3 driver that I've tried to
> >use; however, the RH Enterprise 3 WS driver doesn't work since that
> >kernel is older than the CentOS-3.1 install kernel.
> >
> >I'm trying to create a centOS-3.1 installation driver disk for the 3ware
> >9500S card; however, I'm not having much luck.  I've compiled the
> >drivers on a stock centOS 3.1 install and created a modules.cgz file
> >(using find . -depth | cpio -o -H newc | gzip -c > ../modules.cgz) with
> >the newly-compiled driver modules.  Here are the contents of the
> >modules.cgz file I created:
> >2.4.21-9.0.1.EL.c0BOOT/i386/3w-9xxx.o
> >2.4.21-9.0.1.EL.c0hugemem/i386/3w-9xxx.o
> >2.4.21-9.0.1.EL.c0/i386/3w-9xxx.o
> >2.4.21-9.0.1.EL.c0smp/i386/3w-9xxx.o
> >
> >I've also tried the above without the 'i386' subdirectory.
> >
> >The stock install kernel version is 2.4.21-9.0.1.EL.c0.  That IS what I
> >should use for the modules directory name right?
> >I then created a driver disk with the following files:
> >modinfo
> >modules.cgz
> >modules.dep
> >pcitable
> >rhdd-6.1
> >src
> >
> >When I boot the install CD, I type: "linux dd".  I then tell the
> >installer that the drivers are on fd0.  The installer reads the disk,
> >but doesn't find the driver and gives me this message:
> >"No devices of the appropriate type were found on this driver disk. 
> >Would you like to manually select the driver, continue anyway, or load
> >another driver disk?"
> >
> >Does anybody know what I'm doing wrong?  Am I going about this the hard
> >way?
> >
> >Thanks in advance for any suggestions!
> >-Sean
> >
> >_______________________________________________
> >CentOS mailing list
> >CentOS at
> >
> >  
> >
> _______________________________________________
> CentOS mailing list
> CentOS at