[Centos] How to get 3Ware 9500S controller card working in CentOS 3.1?

Fri Jul 9 12:42:14 UTC 2004
Denis Pilon <dpilon at dpilon.com>

Looking at the 3ware driver disk here is the content

zcat modules.cgz | cpio -ivd
notice... no i386 directory
Plus...the only i386 kernel is the BOOT kernel...please build the 
correct driver for i686 or athlon...depending on your system


Try using the the driver disk from 3ware replacing the modules.cgz.


Sean Staats wrote:

>My goal is to be able to install to the drive array on the 3Ware
>controller card.  3Ware does provide a RH WS 3 driver that I've tried to
>use; however, the RH Enterprise 3 WS driver doesn't work since that
>kernel is older than the CentOS-3.1 install kernel.
>I'm trying to create a centOS-3.1 installation driver disk for the 3ware
>9500S card; however, I'm not having much luck.  I've compiled the
>drivers on a stock centOS 3.1 install and created a modules.cgz file
>(using find . -depth | cpio -o -H newc | gzip -c > ../modules.cgz) with
>the newly-compiled driver modules.  Here are the contents of the
>modules.cgz file I created:
>I've also tried the above without the 'i386' subdirectory.
>The stock install kernel version is 2.4.21-9.0.1.EL.c0.  That IS what I
>should use for the modules directory name right?
>I then created a driver disk with the following files:
>When I boot the install CD, I type: "linux dd".  I then tell the
>installer that the drivers are on fd0.  The installer reads the disk,
>but doesn't find the driver and gives me this message:
>"No devices of the appropriate type were found on this driver disk. 
>Would you like to manually select the driver, continue anyway, or load
>another driver disk?"
>Does anybody know what I'm doing wrong?  Am I going about this the hard
>Thanks in advance for any suggestions!
>CentOS mailing list
>CentOS at caosity.org