[Centos] nVIDIA on CentOS 3.3

Wed Sep 22 07:57:48 UTC 2004
Johnny Hughes <mailing-lists at hughesjr.com>

On Tue, 2004-09-21 at 19:13 -0700, Rick Graves wrote:
> Hey,
> I tried it.  The short answer is that nVIDIA cards are
> OK for text, but may not work at all under X.  
> I downloaded the 3.3 ISO's, and burned new CD's.  I
> did an X desktop install on a test bench P3 600 MHz
> system with a 4.3 gig drive.  I did the install with a
> known-to-work Voodoo Banshee card to get the system
> going.  I used a Mag DX1495 monitor, which I know does
> not to work on Linux with nVIDIA cards (but which
> works just fine running Windows with nVIDIA cards).  
> Everything installed OK with only a minor glitch
> toward the end (just when going into the reboot, after
> setting up the monitor and display card, there were
> some messages about cannot find some graphics files). 
> After going into my regular user account and adjusting
> some preferences, I shut the system down, replaced the
> Voodoo Banshee card with an nVIDIA Riva TNT 2 card,
> and restarted the computer.  During startup, kudzu
> detected the hardware change, and configured the
> machine for the new card following my confirmation. 
> (Windows can do this automatically, why not Linux?)
> Sure enough, when X tried to load, the screen went
> blank.  Not only did the screen go blank for the X
> console #7, but the screen was blank for the 6 other
> consoles as well.  I knew this because I could change
> to my favorite with F2, then Ctl-Alt-del to reboot. 
> The screen stayed blank until the computer began the
> new boot, when the screen came back.  
> This was exactly the situation under CentOS 3.1.  
> Moral of the nVIDIA story: if the monitor/display
> card/motherboard combination works for you, great.  If
> not, using a display card from a different
> manufacturer may be the best solution.
> Rick


The issue is as it was with CentOS 3.1 ... and it probably concerns
either a NFORCE2 motherboard (Which requires the kernel-unsupported and
kernel-source packages to be installed ... and it is not installed by
the default install) ... AND/OR the video card is higher than an FX5200,
and requires the kernel-source package and the binary drivers from
NVIDIA to be installed.

When booting the machine, press "a" at the kernel selection screen to
append the run level and add a "SPACE" and a "3" (no quotes, just
spacebar and 3) to boot in test mode, then do:

yum install kernel kernel-source kernel-unsupported

(if the kernel is upgraded, boot to the new kernel in runlevel 3 again)

then get the latest nvidia drivers with:

wget http://download.nvidia.com/XFree86/Linux-x86/1.0-6111/NVIDIA-Linux-

Then do:

chmod 755  NVIDIA-Linux-x86-1.0-6111-pkg1.run

then do:

IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-6106-pkg1.run

Then edit your /etc/X11/XF86Config file and remove (or remark out)
anything having to do with "dri" and change the driver line to:

Driver "nvidia"

This scenario also requires that the binary driver be recompiled every
time the kernel is changed. 

See my page on this issue for details:



This problem is caused by 2 things ... RedHat not loading all kernel
drivers (ie, having a kernel-unsupported package) and NVIDIA not
providing the code for their hardware to the open source community
(requiring a binary, closed source driver to be installed and recompiled
at every kernel upgrade).

Johnny Hughes