[CentOS] Re: kannel from dag - sqlite conflict with centos 4.2

Alex White ethericalzen at gmail.com
Thu Nov 10 20:49:15 UTC 2005

Tony wrote:
 > Unresolvable chain of dependencies:
> kannel 1.4.0-3.2.el4.rf requires libsqlite.so.0
> The new 3.2.2 version only provides libsqlite3.so.0.
> Anyone else seen this, or have any recommendations as to how I can
> have 4.2with kannel still installed?
> --
> Cheers,
> Tony

If you just need to get it in there, you can force the install after
 making a symlink from libsqlite.so.0 to libsqlite3.so.0. You would
use "ln -s" to do this. "ln --help" will provide you with syntax, I
believe it is "ln -s libsqlite3.so.0 libsqlite.so.0"

This is not a way to solve the dependency, after you do this you
will have to force (--force) the rpm install of the rpm after
downloading it manually.

I only use yum to install a few apps and to update, I've not run
into this problem before using yum. I would wait for more advice on
the issue unless this is somewhat urgent.


Alex White

More information about the CentOS mailing list