[CentOS] OpenIPMI on a SunFire v20z

Johnny Hughes mailing-lists at hughesjr.com
Wed Oct 5 10:31:17 UTC 2005

On Wed, 2005-10-05 at 17:23 +0930, Tom Lanyon wrote:
> Tom Lanyon wrote:
> >Hi all,
> >
> >New to the list and (mostly) new to CentOS. We have just moved from
> >running RHEL to CentOS on our main production servers.
> >
> >Anyway, I am configuring a couple of new SunFire v20z servers here at
> >the moment and trying to get the systems' management interfaces to work
> >fully under CentOS.
> >
> >First issue was trying to install the openipmi RPM from the CD that came
> >with the SunFires, this RPM installs the source for the openipmi kernel
> >drivers and then builds them as kernel modules. First I had to get the
> >kernel source installed (i used the kernel SRPM to install, then did an
> >rpmbuild to create the patched source directory), however I'm now
> >receiving a whole bunch of errors whilst trying to compile the IPMI
> >driver 'ipmi_devintf_src.c' file because of what looks to be
> >incompatibilities with the kernel.
> >My presumption is that this openipmi driver is intented for 2.4.x kernels.
> >
> >So I moved on and discovered that openipmi is built into the 2.6.9-11.EL
> >kernel which is installed by default. I tried inserting these modules:
> >    ipmi_devintf
> >    ipmi_msghandler
> >    ipmi_si
> >    ipmi_watchdog
> >Which produced the following syslog output:
> >    Oct  5 00:02:00 langoria kernel: ipmi message handler version v33
> >    Oct  5 00:02:00 langoria kernel: ipmi device interface version v33
> >    Oct  5 00:02:03 langoria kernel: IPMI System Interface driver
> >version v33, KCS version v33, SMIC version v33, BT version v33
> >    Oct  5 00:02:03 langoria kernel: ipmi_si: Found SMBIOS-specified
> >state machine at I/O address 0xca2
> >    Oct  5 00:02:03 langoria kernel:  IPMI kcs interface initialized
> >    Oct  5 00:02:07 langoria kernel: IPMI Watchdog: driver version v33
> >
> >I thought, "Wonderful! It's working!", and was happy to see that the
> >ipmi device existed:
> >    crw-r--r--  1 root root 254, 0 Oct  4 23:27 /dev/ipmi0
> >(However, it seems like its always been there - not sure why. Doesn't
> >CentOS use udev?)
> >
> >I installed the userland ipmitool software and all was peachy.
> >
> >...But my excitement and fun was ruined when I actually tried to use the
> >tool:
> >    [root at langoria ~]# ipmitool sel
> >    Could not open device at /dev/ipmi0 or /dev/ipmi/0: No such file or
> >directory
> >    Get SEL Info command failed
> >
> >Seems like the OpenIPMI drivers aren't binding to the device?
> >
> >Basically, I'm wondering if anyone has had any experience running
> >openipmi on CentOS 4.1 running the default 2.6.9-11.EL kernel  and can
> >offer any assistance to me?
> >
> >Regards,
> >Tom Lanyon
> >
> List,
> I've worked it out. For future reference to anyone, the version of
> openipmi in the stock CentOS 4.1 2.6.9-11.EL kernel did not support the
> SunFire v20z and v40z server IPMI interface. Either that or I had a
> version of ipmitool which was too new for the version of openipmi in the
> kernel.
> Either way, I fetched the latest openipmi from
> http://linux.dell.com/files/openipmi/ for RHEL4 (in my case it was
> openipmi-33.7.RHEL4-ldkms.tar.gz), uncompressed that file and ran the
> install script which installed openipmi driver sources as well as the
> dkms framework.
> After a quick bit of reading on how dkms worked, I built my new module with:
> "dkms build -m openipmi -v 33.7RHEL4 -k `uname -r` -a x86_64
> --kernelsourcedir=/usr/src/linux --config=/usr/src/linux/.config"
> Then, an "/etc/init.d/ipmi start" worked a treat!
> Hope this helps someone else in the future.
> Cheers,
> Tom
There is an included openimpi in update2 for EL4 that should be
available soon (when update 2 is released upstream).

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://lists.centos.org/pipermail/centos/attachments/20051005/401277d1/attachment.sig>

More information about the CentOS mailing list