[CentOS] MythTV on Centos 4 - Solved

Kirk Bocek t004 at kbocek.com
Thu Oct 6 15:33:18 UTC 2005

Finally got my PVR-350 IR problem solved. Turns out the error was between the 
keyboard and chair...

I was using a One-For-All UNC-8910 remote for testing instead of the gray Hauppauge 
remote that came with the PVR-350. I *assumed* (always a bad thing) that IR receiver 
would accept any signals and that they would show up under the 'raw output' utilities 
like irrecord and mode2... not so.

Most of the default modes on the 8910 are *not* recognized by the PVR-350 IR 
whatsoever. Once I started using the gray Hauppauge remote, everything worked. It 
also works with the 8910 once I use the 'learning mode' of the 8910 to program the 
Hauppauge codes.

<sigh> One of these days I'll get that 'Do What I Want' button installed...


Scot L. Harris wrote:
> On Thu, 2005-09-29 at 12:40, Kirk Bocek wrote:
>>Scot, I believe you said you were using the IR receiver on the PVR-350, right? Do you 
>>have any notes or gotcha's on getting it to work. So far, I'm having no luck.
>>I've got ivtv installed and have got my X session running on the PVR-350's frame 
>>buffer. Now I'm trying to get the IR receiver working but am getting no output out of 
>>I've got lirc 0.7.2 installed. I've got:
>>	alias char-major-61 lirc_i2c
>>in modprobe.conf. When I modprobe lirc_i2c it whines about bttv and cx8800 (which 
>>aren't installed) then says:
>>lirc_i2c: chip found @ 0x18 (Hauppauge IR)
>>ivtv: i2c attach to card #0 ok [client=Hauppauge IR, addr=18]
>>lirc_dev: lirc_register_plugin: sample_rate: 10
>>So it looks like the two pieces are talking. the /dev entries seem to be correct. But 
>>  I get no output at all from irw. No errors either. I even tried plugging in a 
>>second Hauppauge IR receiver into the card that I had laying around.
>>Do you have any ideas?
> On my masterbackend/frontend system it uses FC3 which is probably closer
> to Centos 4.1 (assume that is the version you are using).  
> I have the following entries in /etc/modprobe.conf:
> alias char-major-61 lirc_i2c
> # --- BEGIN: lirc setup ---
> install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install
> lirc_i2c
> # --- END: lirc setup ---
> I believe I found that in Jarod's guide for FC3.  The FC4 install used
> these same lines.  When I set this up on the slave backend/frontend
> system lirc worked first time with irw and then with mythtv.
> I just followed the section in Jarod's guide for setting this up.  Check
> for typos and walk through each step carefully.  Make sure 61 is the
> right number for the device.  Look for the major number 61 in the /dev
> directory.  Should be lirc device or grep for 61.
> And just to make sure the simple things are taken care of, check that
> you put the batteries in the remote.  And that they are installed
> correctly. :)
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

More information about the CentOS mailing list