[CentOS] Problems with Additional IP's, Sendmail, and iptables?

Mickael Maddison centos at silverservers.com
Thu Oct 6 19:29:33 UTC 2005

Hello Will,

Indeed, newaliases runs every few minutes as part of the alias
gathering routines.  In fact, I tested that part, and as far as the
"local" server was concerned, sendmail -bv email at domain.com was set to
route correctly.  The problem I got was that any server connecting to
the machine to send mail to the domain on the recently added IP would
be rejected.

Thanks for pondering.

Best regards,
            mailto:centos at silverservers.com

Thursday, October 6, 2005, 1:33:37 AM, you wrote:

> On 05/10/05, Mickael Maddison <centos at silverservers.com> wrote:
>> When adding the IP, any domains pointing to the IP are added to the
>> local-host-names file, their email aliases are all configured, and
>> sendmail is restarted.  The problem is, none of the aliases ever work
>> unless I actually reboot the entire machine.

> This might be a stupid question but are you running newaliases after
> modifying /etc/aliases?

> If you restart Sendmail with either

> service sendmail restart|reload|stop/start
> /etc/rc.d/init.d/sendmail restart|reload|stop/start

> the newaliases *should* be being run. But it certainly sounds like it
> might not be.

> Will.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

More information about the CentOS mailing list