[CentOS] Changing permissions on files that only exist during USB operation

Dave Gutteridge dave at tokyocomedy.com
Sun Sep 4 16:14:44 UTC 2005

>/etc/security/console.perms would clearly be the wrong place to do that
>this is udev stuff...
Perhaps you could explain why iyt's the wrong place to do this stuff. 
I'm a newbie, and it's not clear. Also, I followed that advice, and it 
seems to have helped.
I also did your cat command, and I'm not really sure what it did, but it 
returned the result you said it would.

>if you are syncing, /dev/pilot is a symbolic link to /dev/ttyUSB1
>what more do you think that you need?
I don't know what I need, I just know what I'm trying to achieve. In 
JPilot, I want to be able to sync, and to install .prc files. When I 
took the error message I got and looked it up on the net, it said it was 
a permissions problem. So if the permissions for /dev/pilot and/or 
/dev/ttyUSB1 are, according to you, what they should be, and other web 
pages say that the permissions are what is stopping it from working, 
then I have no idea what I need.

In any case, the error situation has changed. Now that I have edited 
console.perms, when I hit the sync button and add a .prc file to load, 
it first gives me the same error as before.
But if I press the sync again, it says the following:
J-Pilot: sync PID = 4920
J-Pilot: press the hotsync button on the cradle or "kill 4920"

However, pressing hotsync produced no results.

So I have clearly not yet solved the problem. But now I don't know if 
it's a permissions issue or not, because I seem to be getting told here 
that the permissions are set okay, but the error message is, according 
to some web sites, a symptom of permission problems.

I'm quite confused. More than when I started.


More information about the CentOS mailing list