[CentOS] Changing permissions on files that only exist during USB operation

Craig White craigwhite at azapple.com
Mon Sep 5 03:16:35 UTC 2005

On Mon, 2005-09-05 at 01:14 +0900, Dave Gutteridge wrote: 
> >/etc/security/console.perms would clearly be the wrong place to do that
> >this is udev stuff...
> >  
> >
> Perhaps you could explain why iyt's the wrong place to do this stuff. 
> I'm a newbie, and it's not clear. Also, I followed that advice, and it 
> seems to have helped.
> I also did your cat command, and I'm not really sure what it did, but it 
> returned the result you said it would.
> >if you are syncing, /dev/pilot is a symbolic link to /dev/ttyUSB1
> >what more do you think that you need?
> >  
> >
> I don't know what I need, I just know what I'm trying to achieve. In 
> JPilot, I want to be able to sync, and to install .prc files. When I 
> took the error message I got and looked it up on the net, it said it was 
> a permissions problem. So if the permissions for /dev/pilot and/or 
> /dev/ttyUSB1 are, according to you, what they should be, and other web 
> pages say that the permissions are what is stopping it from working, 
> then I have no idea what I need.
> In any case, the error situation has changed. Now that I have edited 
> console.perms, when I hit the sync button and add a .prc file to load, 
> it first gives me the same error as before.
> But if I press the sync again, it says the following:
> J-Pilot: sync PID = 4920
> J-Pilot: press the hotsync button on the cradle or "kill 4920"
> However, pressing hotsync produced no results.
> So I have clearly not yet solved the problem. But now I don't know if 
> it's a permissions issue or not, because I seem to be getting told here 
> that the permissions are set okay, but the error message is, according 
> to some web sites, a symptom of permission problems.
> I'm quite confused. More than when I started.
well before you can load a program (prc), you have to be able to sync.

jpilot - I thought was one of the easiest of all to make work - it
really didn't seem to require much - unlike some issues that I had with
gpilot (gnome/evolution).

First off...

without sync'ing anything

ls -l /dev/pilot /dev/ttyUSB*

should come up empty...please confirm

then press the sync button on the cradle or 'Hotsync' on your palm and
tell it to connect (I presume that you are using pretty normal
settings...USB - 576000 - flow control automatic

then again...
ls -l /dev/pilot /dev/ttyUSB*

you should see 3 things happening...

# ls -l /dev/pilot /dev/ttyUSB*
lrwxrwxrwx  1 root  root      7 Sep  4 20:07 /dev/pilot -> ttyUSB1
crw-rw----  1 root  uucp 188, 0 Sep  4 20:07 /dev/ttyUSB0
crw-------  1 craig uucp 188, 1 Sep  4 20:07 /dev/ttyUSB1

look familiar? I just checked it - sync'd with gpilot (gnome-
pilotd/evolution) and jpilot (for s&g's)

granted this is FC-3 and not CentOS 4 because I use Fedora for my
desktop but they should be nearly identical for this purpose.

so I would say that if you don't have those devices when you aren't
syncing and you do have those devices when you push the sync button on
the cradle or on the palm - if jpilot is set to use /dev/pilot then the
only issue I can see is the settings... 57600 & auto flow control works
for me.

Perhaps you should make sure that you don't have some old processes
hanging and reboot first.

I think your permissions thing is just a red herring - or in the thread
beginning - advice from RedHat 8 which simply doesn't apply.


More information about the CentOS mailing list