[CentOS] Changing permissions on files that only exist during USB operation [SOLVED]

Dave Gutteridge dave at tokyocomedy.com
Tue Sep 6 15:16:20 UTC 2005

>This should be instructive to you that it is not generally necessary to
>brute force things such as permissions. You should have faith that the
>developers are quite intelligent on these things and what holds us back
>(and I definitely include myself here), is the lack of understanding of
>how things work.
Well, I'm not really sure that description represents the situation. I 
didn't just make up the issue of permissions. In fact, I don't know 
nearly enough about Linux to even conceive of a solution like that.
What I got was an error message, with the word "ERROR" in capital 
letters, and I looked it up on the net. I really can't see how that's an 
unreasonable course of action.

Following that, after I came across a suggestion that it was a 
permissions problem, I came here to this list to ask further, and I 
wasn't told right away "no, that's not a permissions issue, that's a 
different problem". I was told how to possibly modify permissions, and 
got kind of deep into it before someone finally said "hey, maybe it's 
not a permissions problem". So for a while I had a lot of support for 
the idea that it was a permissions problem.

In other words, faith doesn't enter into it. My understanding of Linux 
is only as good as the information I find in response to my queries.

I'm not sure how far I would get if I always assumed I was just doing 
things wrong every time I came across an error message. I've worked with 
computers long enough to know that an error is quite likely to actually 
be an error.


More information about the CentOS mailing list