[CentOS] Disk problem has stopped 'df' from working - UPDATE

Nigel kendrick support-lists at petdoctors.co.uk
Thu Sep 15 12:49:55 UTC 2005

Hi folks, I actually managed to find a message in an old forum somewhere
about a corrupt /etc/mtab file and how to fix it: cat /proc/mounts >
/etc/mtab, but when I tried it I was informed that the filesystem was read

Further checks revealed lots of disk channel errors being logged so I guess
the hard disk may be on the way out after all. I'll be on site with a spare


-----Original Message-----
From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf
Of Nigel kendrick
Sent: 15 September 2005 11:55
To: 'CentOS mailing list'
Subject: [CentOS] Disk problem has stopped 'df' from working

Hi folks, probably not CentOS specific but any help appreciated:

One of our CentOS4 servers crashed and when checked there was a disk problem
which turned out to be a faulty SATA cable on one of the RAID 1 drives. This
was sorted and the server brought back up after the usual disk checks and
all has been well for the last week. Today, however, I tried 'df -h' and

Filesystem            Size  Used Avail Use% Mounted on
df: `': No such file or directory

I can't recall whether I tried the command just after the server was
restarted (ie: whether this is a new problem) but any pointers towards
possible causes/fixes would be appreciated.


CentOS mailing list
CentOS at centos.org http://lists.centos.org/mailman/listinfo/centos

More information about the CentOS mailing list