[CentOS] booting from copied ext3 software raid fs to normal fs

Will McDonald wmcdonald at gmail.com
Tue Sep 27 14:56:14 UTC 2005

On 26/09/05, dan1 <dan1 at edenpics.com> wrote:
> >You could try booting the machine to single user mode. Interrupt the
> >boot at grub, use 'e' for edit, go to the kernel line, hit 'e', add an s
> >on the end of the line and hit 'b' to boot. if you can get to single
> >user mode, then you can try working your way through the various start
> >up scripts to see what is causing the problem.
> Hello, Sean. Thanks for replying.
> I tried your suggestion, but it can't even start linux in single mode.
> I think that there is a mount problem, but I have double checked the fstab
> file seated on the backup drive and it seems fine to me. Therefore I can't
> understand what prevents the mount to be made properly. Would the vmlinuz or
> initrd images be dependent of the md or hd filesystem type or are they
> exactly the same for both ? Else what other file should I touch that
> involves the mounting operation ?

I had very similar symptoms a few weeks back setting up a system,
check the archives for a thread titled "Boot/init problem with IBM
Netfinity 4500".

In my case it actually turned out to be a hardware issue and reseating
processors temporarily fixed it. The long-term fix appears to be to
replace the VRM.

In your case, in /etc/fstab are you mounting by LABEL and are your
partitions labelled as they should be according to fstab? You can use
e2label to view/change partition labels.


More information about the CentOS mailing list